summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-22 10:42:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-22 10:42:49 +0300
commitee7b032d9a0e20b9d84b10fb525ea8adb9632e8c (patch)
treeb5ebbf6ac85aa37d06dceb16cec0bed5dc3996ab /dev-python
parentdev-python/botocore: Stabilize 1.27.88 ALLARCHES, #877867 (diff)
downloadgentoo-ee7b032d9a0e20b9d84b10fb525ea8adb9632e8c.tar.gz
gentoo-ee7b032d9a0e20b9d84b10fb525ea8adb9632e8c.tar.bz2
gentoo-ee7b032d9a0e20b9d84b10fb525ea8adb9632e8c.zip
dev-python/mkdocs-minify-plugin: add 0.6.0, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mkdocs-minify-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/mkdocs-minify-plugin/Manifest b/dev-python/mkdocs-minify-plugin/Manifest
index 70592b54a856..17cda6254a62 100644
--- a/dev-python/mkdocs-minify-plugin/Manifest
+++ b/dev-python/mkdocs-minify-plugin/Manifest
@@ -1 +1,2 @@
DIST mkdocs-minify-plugin-0.5.0.tar.gz 3387 BLAKE2B bce05582eab831976b430d5c331c0e51cecf790f4db6f3bd089ff6f0f5421c0b824c9bf6637a6b00555eee203b23cbd5fc3a0e81fcb5a8697ab7c06e94a9d2e0 SHA512 a31770c9de39439ba5eb4e35acd088aa7df2d7fa39f7942819c0b25429abb7b2b0626765f26f4d4fc77fd11e48dfdf90f9eb93e999cf7b641bb630c852eec50a
+DIST mkdocs-minify-plugin-0.6.0.gh.tar.gz 8069 BLAKE2B 7b2860ecdd1778cc51fca7357fd699578d6805176e9aa21013aec3650b40fa28381350d6690c2188cd04e25259ac71e3c9ca4e005fcc81c33182eb898a218aef SHA512 ad045fe6643de1d979051c58f89ffc5e98eb2063152a3301073864fb2bf3e5a0c183b4362ee175b8fc14be0335d0e76c509b9b6b721cdb78d9add632a46d72e9
diff --git a/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild b/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild
new file mode 100644
index 000000000000..c439b9402e5b
--- /dev/null
+++ b/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An MkDocs plugin to minify HTML and/or JS files prior to being written to disk"
+HOMEPAGE="
+ https://github.com/byrnereese/mkdocs-minify-plugin
+ https://pypi.org/project/mkdocs-minify-plugin/
+"
+SRC_URI="
+ https://github.com/byrnereese/mkdocs-minify-plugin/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/csscompressor-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.4.1[${PYTHON_USEDEP}]
+ >=app-text/htmlmin-0.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jsmin-3.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ~dev-python/mkdocs-minify-plugin-${PV}[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest