summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-20 15:36:53 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-20 15:40:59 +0200
commiteea5ec8ca5839083c5142ee4f58fb5c0d7964c56 (patch)
tree1b545494d0dfa5ec81477365eb7b8578306d80c1 /dev-python
parentdev-python/pylint: Add missing RDEP on configparser, #606554 (diff)
downloadgentoo-eea5ec8ca5839083c5142ee4f58fb5c0d7964c56.tar.gz
gentoo-eea5ec8ca5839083c5142ee4f58fb5c0d7964c56.tar.bz2
gentoo-eea5ec8ca5839083c5142ee4f58fb5c0d7964c56.zip
dev-python/aiohttp-cors: Tested on py3.5 & py3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild
index 82ce007da479..f0c5fa8cee4e 100644
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_4 )
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
inherit distutils-r1
@@ -29,6 +29,13 @@ DEPEND="${RDEPEND}
dev-python/selenium[${PYTHON_USEDEP}]
)"
+python_prepare_all() {
+ # for some reason, it is installed by 'setup.py test' on py!=3.4
+ # TODO: investigate
+ sed -i -e '/typing/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
esetup.py test
}