summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-20 16:18:13 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-20 22:16:08 +0200
commitefe6f094d8b630d95070d27005564fa9e331565c (patch)
tree06657c9140af742b275d7c4bda18ce3870e4991d /dev-python
parentdev-python/netifaces: bump to python 3.10 (diff)
downloadgentoo-efe6f094d8b630d95070d27005564fa9e331565c.tar.gz
gentoo-efe6f094d8b630d95070d27005564fa9e331565c.tar.bz2
gentoo-efe6f094d8b630d95070d27005564fa9e331565c.zip
dev-python/pytest-describe: bump to python 3.{9,10}
passes test Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-describe/pytest-describe-1.0.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild b/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild
index dc72c7e880f9..cce7fb4c6cfb 100644
--- a/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild
+++ b/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -15,16 +15,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( ${RDEPEND} )"
+
+distutils_enable_tests pytest
python_test() {
# We need to disable some plugins because tests don't like unexpected
# output
- PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" pytest -vv ||
- die "Tests failed under ${EPYTHON}"
+ PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" epytest
}