summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-05 09:30:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-05 12:44:32 +0200
commiteff96b794f6f13fc5532a17fdd1ab4b82ea94748 (patch)
tree008e10899a243371fbb84257385e1a6b6b5a2a72 /dev-python
parentnet-libs/libaxc: Fix compilation with clang (diff)
downloadgentoo-eff96b794f6f13fc5532a17fdd1ab4b82ea94748.tar.gz
gentoo-eff96b794f6f13fc5532a17fdd1ab4b82ea94748.tar.bz2
gentoo-eff96b794f6f13fc5532a17fdd1ab4b82ea94748.zip
dev-python/psycopg: Bump to 3.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-3.1.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 56c0dc9b8dd9..fbd06071bde6 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,4 +1,5 @@
DIST psycopg-3.1.1.gh.tar.gz 464501 BLAKE2B 1796ae830051ee0719e4723036ca672ac005793beb88da21b9775cdc96dd4f58b3d008eb3f3a87c3f7293ea097480bbe72a8591b68371d1f7c7261c37927e40f SHA512 a243626c5e0ee0ef414c193b9168f58ec6fa3bfc5652c25c3c1f355f4cea29bcc993ba631a125c0a0335155c15fc068f6cfa5e8974de0cd32e007ae6d3db23dc
DIST psycopg-3.1.2.gh.tar.gz 467017 BLAKE2B 5e13156ff05a356bb59ebae77e8ad3d3e35ab669a43102fa7751927e0ecfbebd1b30db7d62bd0865f426c2e6362a98a6d9cad19c9001abf29b6d030b4dd0204b SHA512 3e412ec91a337012086b1260527b2179883f6b44a26c5e8437c92351ca39594c4430f251abdfbc52e4b2c69d5e91ba09883578b177e836691cd295b6e8464fdf
+DIST psycopg-3.1.3.gh.tar.gz 468400 BLAKE2B 5df0414d1afef4a09a319453e2d9cebd6177af507c30e69aac64dc1d476cf7a0d182c72b81e46d95e3167ee503fa9756ba82ad1092419eea0d6fc3c6e9ba972c SHA512 83ca6dc81cff841c9e22ad8ae86500be0012ee0edbc50b8ab97dcdcbe9d17a8b32feb637275bbaef8333f252aeb961fc5f1f9d2c66dcb1e92b0a1b67223624fb
DIST psycopg-3.1.gh.tar.gz 463892 BLAKE2B 94100bed4807771f6c4d0469737b160955f3f6bfcff84240c9e15dd9b7b88765583952b712642740c97f6ec42223edcf74fb2c5390a185f44ca0eb8858e76100 SHA512 057a14d614ccb9f36a7db7a82c3d48953658a1c6af2a2265a93a3f6c1db421275e51e1be4d59e2ea98b638f3da8c24c9d2a4d9aabf6190c47691dd632c9339f9
DIST psycopg2-2.9.3.tar.gz 380611 BLAKE2B 78099da7378dcfa8b7f28aae4d533a7e890cdb7ae4c0cc718a9411e630fd07b56f074760fc29de8fe08fe727328cca39414a5f297fb92ed2f7471a24e633d18d SHA512 048184d1d162a371fc0fba711448a6fa8a6aac193421f4484c7f7b91c39065d5b632fa34fc15a901eca055d597302b1f9e38330b248ed0e4653dcdc544b0d660
diff --git a/dev-python/psycopg/psycopg-3.1.3.ebuild b/dev-python/psycopg/psycopg-3.1.3.ebuild
new file mode 100644
index 000000000000..8bd1346c397b
--- /dev/null
+++ b/dev-python/psycopg/psycopg-3.1.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="
+ https://www.psycopg.org/psycopg3/
+ https://github.com/psycopg/psycopg/
+ https://pypi.org/project/psycopg/
+"
+SRC_URI="
+ https://github.com/psycopg/psycopg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/psycopg
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+DEPEND="
+ >=dev-db/postgresql-8.1:*
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/backports-zoneinfo-0.2.0[${PYTHON_USEDEP}]
+ ' 3.8)
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-db/postgresql-8.1[server]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests for the psycopg_pool package
+ tests/pool
+ # some broken mypy magic
+ tests/test_module.py::test_version
+ tests/test_module.py::test_version_c
+ tests/test_typing.py
+ tests/crdb/test_typing.py
+ # TODO, relying on undefined ordering in Python?
+ tests/test_dns_srv.py::test_srv
+)
+
+src_test() {
+ # tests are lurking in top-level directory
+ cd .. || die
+
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" test || die
+
+ local -x PSYCOPG_TEST_DSN="host=${T} dbname=test"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}