summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-01-02 07:44:30 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2018-01-02 07:45:27 -0700
commitf0ac4e6e53dc44334de4c9ea7e0fc5f704d2ba6c (patch)
tree2ca2019b64b7f52f13dac12d5c835ebd55d3e3a3 /dev-python
parentsys-fs/udftools: Removed old. (diff)
downloadgentoo-f0ac4e6e53dc44334de4c9ea7e0fc5f704d2ba6c.tar.gz
gentoo-f0ac4e6e53dc44334de4c9ea7e0fc5f704d2ba6c.tar.bz2
gentoo-f0ac4e6e53dc44334de4c9ea7e0fc5f704d2ba6c.zip
dev-python/python-hpilo: New package
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-hpilo/Manifest1
-rw-r--r--dev-python/python-hpilo/metadata.xml19
-rw-r--r--dev-python/python-hpilo/python-hpilo-4.0.ebuild21
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-hpilo/Manifest b/dev-python/python-hpilo/Manifest
new file mode 100644
index 000000000000..6ebfa3f4d343
--- /dev/null
+++ b/dev-python/python-hpilo/Manifest
@@ -0,0 +1 @@
+DIST python-hpilo-4.0.tar.gz 178109 BLAKE2B aa8d4f9f74c053cb65d6c1ae77602a045923250aa9e4e3d689aa305094bb91a3a100a365d28fbb5fb0b69887d27a00796ffa2d9ff9f5eb26800f18672f73a6c6 SHA512 5a084899275b169a753d93b599c6b0d4d46d695c1378bbea340740d9e654723ff44e85cb71213c2e6811356d826e3912598b18f0f1aaeb906f19b0fc3064fbde
diff --git a/dev-python/python-hpilo/metadata.xml b/dev-python/python-hpilo/metadata.xml
new file mode 100644
index 000000000000..ab62601285cf
--- /dev/null
+++ b/dev-python/python-hpilo/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ HP servers come with a powerful out of band management
+ interface called Integrated Lights out, or iLO. It has an
+ extensive web interface and commercially available tools for
+ centrally managing iLO devices and their servers.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">seveas/python-hpilo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-hpilo/python-hpilo-4.0.ebuild b/dev-python/python-hpilo/python-hpilo-4.0.ebuild
new file mode 100644
index 000000000000..a291d1ad427b
--- /dev/null
+++ b/dev-python/python-hpilo/python-hpilo-4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="iLO automation from python or shell"
+HOMEPAGE="https://pypi.python.org/pypi/python-hpilo"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ ${EPYTHON} -m unittest discover || die
+}