summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-15 00:05:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-15 00:05:18 +0200
commitf210af821661f51331a169ea630b94e4e4475b44 (patch)
tree06121a0dbcf840c9d3de045cc422289c84f0c129 /dev-python
parentdev-python/sphinx: Bump to 4.1.1 (diff)
downloadgentoo-f210af821661f51331a169ea630b94e4e4475b44.tar.gz
gentoo-f210af821661f51331a169ea630b94e4e4475b44.tar.bz2
gentoo-f210af821661f51331a169ea630b94e4e4475b44.zip
dev-python/tox: Bump to 3.24.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.24.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 4f37b818d4cf..07b0397c7006 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1 +1,2 @@
DIST tox-3.23.1.tar.gz 303896 BLAKE2B d59160035a6412a69f9434bfb5b2b27aa9a2ebd5344b4898b677dac15dc91ab94feca67b8edde4c0ba68c8a6a12fa885091d82a088439257e9393a99e77ade88 SHA512 ec5daf106287b265d1abec8465df8ad053ecf59876038a7cb419a57e22373809e50f8131736762dc485f559363b1878abb49d909e7b6952b2e49eea77c193281
+DIST tox-3.24.0.tar.gz 304960 BLAKE2B 5f6256d27d75651929f2d4d511f6137f20c71ab44c57e5b908c0ba92d5d7998ad5df69bd937a963bdf27625eefb222b9be2c7dffbf44684092ef345f4e33d0ba SHA512 94879cb65c1d41cfca02b23c7d540b93f5d3667ce72135969c584f09e00e3a246d80851f7cefad1e199f0a56c526e4ffa31c2938428b6632a38ad72388925dcd
diff --git a/dev-python/tox/tox-3.24.0.ebuild b/dev-python/tox/tox-3.24.0.ebuild
new file mode 100644
index 000000000000..4fb372991c77
--- /dev/null
+++ b/dev-python/tox/tox-3.24.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
+ ' pypy3)
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local deselect=(
+ # broken without Internet
+ tests/unit/session/test_provision.py::test_provision_non_canonical_dep
+ tests/integration/test_provision_int.py::test_provision_interrupt_child
+
+ # expects python2 to exist
+ tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
+ )
+
+ [[ ${EPYTHON} != pypy3 ]] && deselect+=(
+ # TODO?
+ tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
+
+ # broken without tox installed first
+ # TODO: why it can't import itself?
+ tests/integration/test_parallel_interrupt.py::test_parallel_interrupt
+ )
+
+ distutils_install_for_testing --via-venv
+ epytest --no-network ${deselect[@]/#/--deselect }
+}