summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-28 09:44:38 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-28 10:07:03 +0100
commitf28fbc871d4387c9b9ff9d44fa0d49511f1d84f9 (patch)
tree81a01aa4dc24dd03bd437390fc5ca2062b0dbbe7 /dev-python
parentdev-python/zstandard: Bump to 0.15.2 (diff)
downloadgentoo-f28fbc871d4387c9b9ff9d44fa0d49511f1d84f9.tar.gz
gentoo-f28fbc871d4387c9b9ff9d44fa0d49511f1d84f9.tar.bz2
gentoo-f28fbc871d4387c9b9ff9d44fa0d49511f1d84f9.zip
dev-python/hypothesis: Bump to 6.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.3.4.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index df798751c64f..47f2fc5b2754 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-6.3.0.tar.gz 9108690 BLAKE2B 1b46da2ea5b1eafeb49df28aadbc
DIST hypothesis-python-6.3.1.tar.gz 9112495 BLAKE2B 4c6f58911bfa45fe82681631109a9e4ad75927f6970d8fff60ec4a6d0fb2d1ec8a0b345163128b26a902e864984444947d7c96a027b26eae8a11c4f3e4fe6cd7 SHA512 6b595942ecb27684f97efb84b1c671bfcd77040516d83cb568e08a47a7add13aeb5c4f47e2e2cd3d84c52911f271d07382e4607cfcdbc751dc754bfbfb07336b
DIST hypothesis-python-6.3.2.tar.gz 9112580 BLAKE2B eb74e089fc5f1f33ec0f34858c0492fd6526f9a61897f94780b5c63f50374e50c61c8a59535bb3814fa9a59478c59f3e43eedde4d401e1ff3fb6fe039d2e3cdf SHA512 b8ea74ce8e479734aa8973d0127351064ccfb3ac6308aad67a57c6545d12a0594b7946f05aabd4bbaa2ddb5ec0ac2959e09db8733cf9e3a96181740aafae8813
DIST hypothesis-python-6.3.3.tar.gz 9112864 BLAKE2B 8eeb01d17aad81188856464c488002f29080c92e7dcc150e9189875c070150c2203e208f25527e3ee8163c4aa9a2a72c0fe6f19c4c992e86f59d53f8dc22bdaf SHA512 803755e6cddb2de4b44df707c75858154a97d7888d4009ac4c4d3b577c5d58571176fe4155025c77e1d59843334f82babf0d7998557404d5964d0547e7c1428a
+DIST hypothesis-python-6.3.4.tar.gz 9112374 BLAKE2B 78867f0ff142d6059a20c437c3fab333de06eff5247d93c1e70f75d801e54984c20da01322b7d4d4999cb30f2c59c6e7cf955fe60ecc0e90b452b8ddf6b6f2ff SHA512 7baee8758d86afbb0a8a16e18b2f14d3870ee2f5623857fc691ca1afc7f0c6555b367fbe758ff02c08af492b4569ef2aeb8d61bf3bd91ac458312a43b02d02f6
diff --git a/dev-python/hypothesis/hypothesis-6.3.4.ebuild b/dev-python/hypothesis/hypothesis-6.3.4.ebuild
new file mode 100644
index 000000000000..46ee7df74d3c
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.3.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}