summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:43:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:54:04 +0200
commitf328488de163546f88b9caf355a17c3945254596 (patch)
treec93458c9830807ad7d0a294dc3c15885d9de8a2e /dev-python
parentdev-python/pip: Remove redundant versions (diff)
downloadgentoo-f328488de163546f88b9caf355a17c3945254596.tar.gz
gentoo-f328488de163546f88b9caf355a17c3945254596.tar.bz2
gentoo-f328488de163546f88b9caf355a17c3945254596.zip
dev-python/pipenv: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pipenv/Manifest1
-rw-r--r--dev-python/pipenv/pipenv-2018.11.26.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index cf530a16f7e7..6f446f94a2e2 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1,2 +1 @@
-DIST pipenv-2018.11.26.tar.gz 6560580 BLAKE2B a3846de696733b5f3f393163999d7f333b52accdcebadfd800507defd1108ac4ccb288b39fb805ecf03e417cfe0d1a8b2fc714a95e8ee4485f8622ff8fe4a1ca SHA512 59582ad4a0730083ea58867f7a5d9714290d62947f56bec80e154d4359fe1dff16e44974a7fba3841e5f2516f2ce9709baf9954c9fc40fd66ebc46c3060d4dea
DIST pipenv-2020.4.1_beta1.tar.gz 11331009 BLAKE2B 55ac81238b885bdf0293199ca1caf44a78f3cdbec75c9df259411b949dec8b385161e7ef46160ca099ef51041410d8c5d1274ad200eba5c2a9d06c8a5f61c5f1 SHA512 a5de90ae9910a30666ac7323ccf83b78ee11d8993aef1a2108a44f4256d365d0c1abfff72c83748ef82215914931090c670a10eeb511cb48483762b54c80e5c7
diff --git a/dev-python/pipenv/pipenv-2018.11.26.ebuild b/dev-python/pipenv/pipenv-2018.11.26.ebuild
deleted file mode 100644
index 9e1ef31da4a4..000000000000
--- a/dev-python/pipenv/pipenv-2018.11.26.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Development Workflow for Humans"
-HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-clone-0.2.5[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
- >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
- "
-DEPEND="
- >=dev-python/parver-0.2[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-# not completely packed
-# requires networking
-RESTRICT="test"
-
-python_test() {
- py.test -v -v || die
-}