summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-28 14:21:30 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-28 14:21:30 -0700
commitf3575030148e54b9f5fbedad0a88a099516ca11e (patch)
treea09fdfc5cc9023b9208d27edc258f4f65b5d7e18 /dev-python
parentprofiles: remove squid mask (diff)
downloadgentoo-f3575030148e54b9f5fbedad0a88a099516ca11e.tar.gz
gentoo-f3575030148e54b9f5fbedad0a88a099516ca11e.tar.bz2
gentoo-f3575030148e54b9f5fbedad0a88a099516ca11e.zip
dev-python/pympler: Version bump to 0.6
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pympler/Manifest1
-rw-r--r--dev-python/pympler/pympler-0.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pympler/Manifest b/dev-python/pympler/Manifest
index e41570df645c..27c2724d1bea 100644
--- a/dev-python/pympler/Manifest
+++ b/dev-python/pympler/Manifest
@@ -1 +1,2 @@
DIST pympler-0.5.tar.gz 263627 BLAKE2B 5ce881664e2d57d1a7a9b87238cfc6657fd35a140e6ab906b55ca6e0ac91fc8a74377d4db21706708c55773f8ca65d3578c101669ba409339418e09ca53d0fb2 SHA512 254b758df70bafe57f315a973de0caeef6cd616bd0cc7b4475c74c3a9a94f52b3ac3da3f073483db3560cd0060536c95ed1297007c24dfe8db89fd893ff1409c
+DIST pympler-0.6.tar.gz 267267 BLAKE2B 84a8df3177d0defed949869bec9342beb4336c912be5539c597388207abcbc53fa5218da34b16a872dca804ff559a448dc092b4d33396d570164311c1808765a SHA512 891822ce0a76377d74aa99dd2ce8b21a364084f0bc03ab6d6fe505597a0e182dde459b218dff8e0e6a753e1d88ba9f01b3a4b97be31a20e73a93d6c6fee66e1b
diff --git a/dev-python/pympler/pympler-0.6.ebuild b/dev-python/pympler/pympler-0.6.ebuild
new file mode 100644
index 000000000000..03f9d85458ee
--- /dev/null
+++ b/dev-python/pympler/pympler-0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="Pympler"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Memory profiling for Python applications"
+HOMEPAGE="https://pypi.org/project/Pympler/ https://github.com/pympler/pympler"
+SRC_URI="https://github.com/pympler/pympler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# The PyPi tarball is missing the documentation
+#SRC_URI="mirror://pypi/P/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/bottle[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ sphinx-build -b html doc/{source,html} || die
+ fi
+}
+
+python_test() {
+ esetup.py try
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}