summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-29 20:56:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-29 20:56:14 +0300
commitf4db55a1be0b3305ad0bd4d9b9e9165f063863fe (patch)
tree9978dd866be8a2073e3874b0fab2ef65db8ea1c2 /dev-python
parentdev-python/curtsies: enable py3.11 (diff)
downloadgentoo-f4db55a1be0b3305ad0bd4d9b9e9165f063863fe.tar.gz
gentoo-f4db55a1be0b3305ad0bd4d9b9e9165f063863fe.tar.bz2
gentoo-f4db55a1be0b3305ad0bd4d9b9e9165f063863fe.zip
dev-python/imageio: add 2.21.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.21.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index ac795f62c33e..0545ff47c600 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -3,3 +3,4 @@ DIST imageio-2.19.5.gh.tar.gz 389832 BLAKE2B a4455f97d2607d215ba4797e076487f4648
DIST imageio-2.20.0.gh.tar.gz 390281 BLAKE2B 745364f98e3835c428e89abbfbeeb657d10cd730cd61283e5859b10a6e48b63a5b9771860fce75aa8dd770ab77671979847b34bbffe17d215fac5ceb8eb2c7d1 SHA512 fc1c41559cc15b76bfacbf4866717c200889661787de4baa49d69fab189ff7d00e376afdeeaaf74b5581e1ffc96da2f02566dfa9c0953518b98a4c4b695ddf02
DIST imageio-2.21.0.gh.tar.gz 391056 BLAKE2B 90fbacf7b396ab2b422d8694274ddc3642c92cfd325bce2861100f5bd28d82120cef6819b53b8ed82ba474d5e287765b63da9a7edfbfab5a026790a39d4edc1e SHA512 5bb070da560ba3a2e10bdb288ad539274ee14f8cf0543847859f0bae052b3d1782777d823435b74120bcfdff0b6cb15a6c80b2a9bf729439bbb3802f15cf5684
DIST imageio-2.21.1.gh.tar.gz 391159 BLAKE2B 4c569ec81255d1f5985d2d30f303a978f9cb22e0d7368845648ddab9e5734adba52173d42ad73c94c424ce1a5806c3a10ae31381b04949f7f8c30fd327b585b4 SHA512 61fd4a1a64fb152fa5c419cac9a69ea979ac762fbaed81076ddd13602db98f71f31825615111958f21b021213d55be060197417159022bba84d631618f5bb286
+DIST imageio-2.21.2.gh.tar.gz 392425 BLAKE2B 959c89627188aca0072f519f0f9c3a9fcf2da96883f95760375bea503efd96ff6a198ad7e8bc12dfffe6aecf42f4b07176c8d273c6d349b5e2581053ddefecb6 SHA512 69922f05457f050083e92dbce34992911d5fb04f283d6784a8e1fd7f10e7887ffeef343d8f4162efaa55690f363ed6ceb5d2cdc5ee712ae9b276f072fdc45d37
diff --git a/dev-python/imageio/imageio-2.21.2.ebuild b/dev-python/imageio/imageio-2.21.2.ebuild
new file mode 100644
index 000000000000..6770d9759db9
--- /dev/null
+++ b/dev-python/imageio/imageio-2.21.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="
+ https://imageio.readthedocs.io/en/stable/
+ https://github.com/imageio/imageio/
+ https://pypi.org/project/imageio/
+"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# over 50% of tests rely on Internet
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+# requests for fsspec[github]
+BDEPEND="
+ test? (
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+ # Tries to download ffmpeg binary ?!
+ tests/test_ffmpeg.py::test_get_exe_installed
+)