summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-26 13:12:23 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-26 13:14:48 -0500
commitf4e053574cfeb9ec1657e4181858b6b48f950dec (patch)
tree4cb410841264d02554e75ed41d5be21f399dce38 /dev-python
parentdev-python/pyopenssl: version bump to 17.4.0 (diff)
downloadgentoo-f4e053574cfeb9ec1657e4181858b6b48f950dec.tar.gz
gentoo-f4e053574cfeb9ec1657e4181858b6b48f950dec.tar.bz2
gentoo-f4e053574cfeb9ec1657e4181858b6b48f950dec.zip
dev-python/snakeoil: version bump to 0.7.5
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.5.ebuild35
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild2
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index 4e79c6a54b5b..722b00cd9fda 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1 +1,2 @@
DIST snakeoil-0.7.4.tar.gz 301878 SHA256 67280c86e4b02c34100603d7525270c0017e0d182df54ad31ec2e5c145e69ceb SHA512 b3ae2223a267fa74699664470a4c4f6888cf2b68e688fe61d3acca85e00a138c3a037482ef304ee26f326cba252b473d265dcd72d0e0ab5723f4b0ed6e5e04ce WHIRLPOOL c76905b7540ad1ab2186d2ce9a75a55660eb343a1cfefc835f8012f3cf10ad706ee837a995085fa327f38de8f790cc2155c540e5b0d2a6f90a0aebbf7198c7bb
+DIST snakeoil-0.7.5.tar.gz 303270 BLAKE2B 66d00cf50c8efd73d765904b9c7e8ba725caef9608e68f5707ddc09358507fe64214af73b333ec5bee2ef950d8dbad474cb5d9e4412757bc3c82d75909f6fc23 SHA512 b9f6efce2e3f5df83248b1faa84493aa11d8a08935e3991a56daace96e0de39dd5c7d25a69a4394f7ba163de78ed56a2619ef64c33114128fc02052d676a86a5
diff --git a/dev-python/snakeoil/snakeoil-0.7.5.ebuild b/dev-python/snakeoil/snakeoil-0.7.5.ebuild
new file mode 100644
index 000000000000..38a023db443b
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.7.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
+
+python_configure_all() {
+ # disable snakeoil 2to3 caching
+ unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index c037456a6ebe..38a023db443b 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
fi
DESCRIPTION="misc common functionality and useful optimizations"