summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-05 09:17:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-05 11:41:01 +0200
commitf4e0612045341df3a0bf4aa65565c8a265b43b1a (patch)
tree4229ee475e0aabb4bd5ebde31408194a136a8f97 /dev-python
parentdev-python/hypothesis: Bump to 6.56.1 (diff)
downloadgentoo-f4e0612045341df3a0bf4aa65565c8a265b43b1a.tar.gz
gentoo-f4e0612045341df3a0bf4aa65565c8a265b43b1a.tar.bz2
gentoo-f4e0612045341df3a0bf4aa65565c8a265b43b1a.zip
dev-python/aesara: Bump to 2.8.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.8.7.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 9bb4c2fd27ac..e850157060e7 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,2 +1,3 @@
DIST aesara-rel-2.7.9.gh.tar.gz 7919763 BLAKE2B f877edcc824f3d790a56422a0fa660e8e3f653fff7e3d87ef4a95fa76369b1bb5df351a571ea039d66d79c0f564512437672df76c3b82e7d660c865cf908dea3 SHA512 061f7e39343eb081b28dd20b1eb7ffc226b7e4b96695d5beb9e28eb3f5ec9480c02c7889c932290248baa908dc0047c19e4cef3c220eccc4cc617b2050a9614e
DIST aesara-rel-2.8.6.gh.tar.gz 7941385 BLAKE2B 8e01e8afe7a4a33ad133d2759336dea66223c7f001c963d937bcae903f315b4dffbd0e877fbfe2f1b7f31b7f73acd8b7ac38a716337aa129b9a36b0367715f96 SHA512 abfa9f63f096eb6d8961eaa700a13f41833ba79d684b83fbcd7bf4a9d8f0ab49eae1bc3d1249817cf03f63526127612482cbc79c03bf2596743caca810f1fc56
+DIST aesara-rel-2.8.7.gh.tar.gz 7944368 BLAKE2B e4b9bf0df3d5bc1745645b4034ca8b94e6a8dbf12bc884df2b0c7701634b4b2015d6fdbf77854da88c6fc6ed89b369a561a289522c7790add70ff281c6088b8f SHA512 0b847424a0e91c4e07b8edefb5f8d1ef46e476c4622fade95f2a7a3b459097c82b62b6f215d98d4de8e8511e50a0a82e4c3b7573d45ac0e0c8ec3b80ae9c61f8
diff --git a/dev-python/aesara/aesara-2.8.7.ebuild b/dev-python/aesara/aesara-2.8.7.ebuild
new file mode 100644
index 000000000000..00f30feaabf6
--- /dev/null
+++ b/dev-python/aesara/aesara-2.8.7.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+MY_P=aesara-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="
+ https://github.com/aesara-devs/aesara/
+ https://pypi.org/project/aesara/
+"
+SRC_URI="
+ https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/etuples[${PYTHON_USEDEP}]
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+ dev-python/minikanren[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/numpy-1.23[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-48.0.0[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
+)
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not claim "bin" package (sic!)
+ rm bin/__init__.py || die
+ sed -e 's/find:/find_namespace:/' \
+ -e '/exclude =/a\ doc*' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+
+ # rounding problem?
+ # https://github.com/aesara-devs/aesara/issues/477
+ tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
+ tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
+
+ # dunno
+ 'tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak[False]'
+
+ # TODO
+ tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
+ tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
+ tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
+ )
+ local EPYTEST_IGNORE=(
+ # we do not package jax or numba
+ tests/link/jax
+ tests/link/numba
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x AESARA_FLAGS="cxx=${CXX}"
+ AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
+ AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
+
+ epytest -p xdist.plugin -n "$(makeopts_jobs)"
+ # clean up the compiledir, as it can grow pretty large
+ rm -r "${HOME}"/.aesara || die
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}