summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-16 19:37:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-16 19:38:05 +0100
commitf580c35947fac3dc7d48795941be7e61660699f1 (patch)
tree9c966f4ad9935b18fd57a17e344c6f4f86147d4e /dev-python
parentdev-python/confusable-homoglyphs: add github upstream metadata (diff)
downloadgentoo-f580c35947fac3dc7d48795941be7e61660699f1.tar.gz
gentoo-f580c35947fac3dc7d48795941be7e61660699f1.tar.bz2
gentoo-f580c35947fac3dc7d48795941be7e61660699f1.zip
dev-python/vcrpy: Fix compatibility with patched httpbin
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/vcrpy/files/vcrpy-6.0.1-httpbin-compat.patch40
-rw-r--r--dev-python/vcrpy/vcrpy-6.0.1.ebuild5
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/vcrpy/files/vcrpy-6.0.1-httpbin-compat.patch b/dev-python/vcrpy/files/vcrpy-6.0.1-httpbin-compat.patch
new file mode 100644
index 000000000000..4e2a91cb4bac
--- /dev/null
+++ b/dev-python/vcrpy/files/vcrpy-6.0.1-httpbin-compat.patch
@@ -0,0 +1,40 @@
+From e60dafb8dce589e7deb63fec552f5c05bd19ac6d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 16 Feb 2024 19:33:41 +0100
+Subject: [PATCH] Improve test compatibility with legacy httpbin index
+
+Make the tests slightly more flexible to match both the flasgger-based
+and legacy httpbin index. This is needed for compatibility with
+https://github.com/psf/httpbin/pull/44 when flasgger is not installed
+(e.g. on architectures that are not supported by Rust).
+---
+ tests/integration/test_basic.py | 2 +-
+ tests/integration/test_register_persister.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/integration/test_basic.py b/tests/integration/test_basic.py
+index bfad6153..99121456 100644
+--- a/tests/integration/test_basic.py
++++ b/tests/integration/test_basic.py
+@@ -39,7 +39,7 @@ def test_basic_json_use(tmpdir, httpbin):
+ test_fixture = str(tmpdir.join("synopsis.json"))
+ with vcr.use_cassette(test_fixture, serializer="json"):
+ response = urlopen(httpbin.url).read()
+- assert b"A simple HTTP Request &amp; Response Service." in response
++ assert b"HTTP Request &amp; Response Service" in response
+
+
+ def test_patched_content(tmpdir, httpbin):
+diff --git a/tests/integration/test_register_persister.py b/tests/integration/test_register_persister.py
+index e904197c..375f14be 100644
+--- a/tests/integration/test_register_persister.py
++++ b/tests/integration/test_register_persister.py
+@@ -66,7 +66,7 @@ def test_load_cassette_with_custom_persister(tmpdir, httpbin):
+
+ with my_vcr.use_cassette(test_fixture, serializer="json"):
+ response = urlopen(httpbin.url).read()
+- assert b"A simple HTTP Request &amp; Response Service." in response
++ assert b"HTTP Request &amp; Response Service" in response
+
+
+ def test_load_cassette_persister_exception_handling(tmpdir, httpbin):
diff --git a/dev-python/vcrpy/vcrpy-6.0.1.ebuild b/dev-python/vcrpy/vcrpy-6.0.1.ebuild
index 6e8afec2a509..257bac69d0b4 100644
--- a/dev-python/vcrpy/vcrpy-6.0.1.ebuild
+++ b/dev-python/vcrpy/vcrpy-6.0.1.ebuild
@@ -38,6 +38,11 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/kevin1024/vcrpy/pull/823
+ "${FILESDIR}/${P}-httpbin-compat.patch"
+)
+
python_test() {
local EPYTEST_DESELECT=(
# these tests are failing with recent dev-python/werkzeug; losely related: