summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-19 16:14:30 +0000
committerSam James <sam@gentoo.org>2021-11-19 16:14:30 +0000
commitf632e9ee46258992440f1e4c43e658cf6b607223 (patch)
treec353c3e3aa9805244897b0429fa88112a7f6267b /dev-python
parentdev-python/numpy: skip arm features test on armv8 (arm32 chroot on arm64) (diff)
downloadgentoo-f632e9ee46258992440f1e4c43e658cf6b607223.tar.gz
gentoo-f632e9ee46258992440f1e4c43e658cf6b607223.tar.bz2
gentoo-f632e9ee46258992440f1e4c43e658cf6b607223.zip
dev-python/numpy: use unknown arch if uname fails
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numpy/numpy-1.21.3-r1.ebuild2
-rw-r--r--dev-python/numpy/numpy-1.21.4-r1.ebuild2
-rw-r--r--dev-python/numpy/numpy-1.21.4.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/numpy/numpy-1.21.3-r1.ebuild b/dev-python/numpy/numpy-1.21.3-r1.ebuild
index e8572b3cbd81..514a34b8e87a 100644
--- a/dev-python/numpy/numpy-1.21.3-r1.ebuild
+++ b/dev-python/numpy/numpy-1.21.3-r1.ebuild
@@ -118,7 +118,7 @@ python_test() {
numpy/typing/tests/test_typing.py::test_reveal[arrayterator.py]
)
- if use arm && [[ $(uname -m) == "armv8l" ]] ; then
+ if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then
# Degenerate case. arm32 chroot on arm64.
# bug #774108
deselect+=(
diff --git a/dev-python/numpy/numpy-1.21.4-r1.ebuild b/dev-python/numpy/numpy-1.21.4-r1.ebuild
index a3e5dbab9bab..144d2a9d4574 100644
--- a/dev-python/numpy/numpy-1.21.4-r1.ebuild
+++ b/dev-python/numpy/numpy-1.21.4-r1.ebuild
@@ -118,7 +118,7 @@ python_test() {
numpy/typing/tests/test_typing.py::test_reveal[arrayterator.py]
)
- if use arm && [[ $(uname -m) == "armv8l" ]] ; then
+ if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then
# Degenerate case. arm32 chroot on arm64.
# bug #774108
deselect+=(
diff --git a/dev-python/numpy/numpy-1.21.4.ebuild b/dev-python/numpy/numpy-1.21.4.ebuild
index a78dda1d1f34..114e5f17f876 100644
--- a/dev-python/numpy/numpy-1.21.4.ebuild
+++ b/dev-python/numpy/numpy-1.21.4.ebuild
@@ -117,7 +117,7 @@ python_test() {
numpy/typing/tests/test_typing.py::test_reveal[arrayterator.py]
)
- if use arm && [[ $(uname -m) == "armv8l" ]] ; then
+ if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then
# Degenerate case. arm32 chroot on arm64.
# bug #774108
deselect+=(