summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 08:36:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 11:21:24 +0100
commitf653e855548a01a1cbd9505a43675540e62d55ad (patch)
tree1bef4d4b9fe86697912d4688aa40c6cc89c1c3a5 /dev-python
parentdev-python/tomli: Bump to 2.0.0 (diff)
downloadgentoo-f653e855548a01a1cbd9505a43675540e62d55ad.tar.gz
gentoo-f653e855548a01a1cbd9505a43675540e62d55ad.tar.bz2
gentoo-f653e855548a01a1cbd9505a43675540e62d55ad.zip
dev-python/isodate: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/isodate/Manifest1
-rw-r--r--dev-python/isodate/isodate-0.6.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/isodate/Manifest b/dev-python/isodate/Manifest
index 2b503a30fc90..2b123252cee2 100644
--- a/dev-python/isodate/Manifest
+++ b/dev-python/isodate/Manifest
@@ -1 +1,2 @@
DIST isodate-0.6.0.tar.gz 28480 BLAKE2B a7499c736b67193ac73026df7a7c9d9bd5b743a5d556fe5e8ba0a62e8a5238d64afb88547a27e4bcbe706483e3e1e97eecd437e4e1c730c20652cff5926502fc SHA512 e977748e13ee2c94ab47bfc47113d152280e9acff6f70e773de73717392148dd2c111a7db2d9fa3679d37936c6ed9a23dc526cb00bd601df45459b6a244f9f7d
+DIST isodate-0.6.1.tar.gz 28443 BLAKE2B 2b451e4dd9a9979feb930090cf045b21c984e962222edc59eff6f08a448258833ac5c368701ed2a703d48c1238122cbe7f628d136124920730bbd96fa04519dc SHA512 437e420ec7ee68dedded825f30d3289eeb0da526208443e5a8e50fe70f12309515e1285b21132d26e6d4c1683f90dfa1d401582042b5e4381fe7ab0e34af26b6
diff --git a/dev-python/isodate/isodate-0.6.1.ebuild b/dev-python/isodate/isodate-0.6.1.ebuild
new file mode 100644
index 000000000000..e6be6118fb17
--- /dev/null
+++ b/dev-python/isodate/isodate-0.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formatter"
+HOMEPAGE="https://pypi.org/project/isodate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s "${BUILD_DIR}/lib"
+}