summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 08:33:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 09:56:20 +0200
commitf7823929a740de5d36704dfd3156deed4685738b (patch)
treee782c8579ab90ceec131a2790034c330bef3fcbf /dev-python
parentdev-java/maven-bin: bump to 3.8.1 (diff)
downloadgentoo-f7823929a740de5d36704dfd3156deed4685738b.tar.gz
gentoo-f7823929a740de5d36704dfd3156deed4685738b.tar.bz2
gentoo-f7823929a740de5d36704dfd3156deed4685738b.zip
dev-python/sphinx-gallery: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.9.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 16f18bc753bb..142a51353969 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1 +1,2 @@
DIST sphinx-gallery-0.8.2.tar.gz 6530210 BLAKE2B ba1500b9870d89c686dd1afbcab4797e15944cbda4d8d2faf02bb65435fa4208bf7dfae70285c920ad2f3b82bc085b06629fb3d2807462f92e75be91ef1e81a8 SHA512 52dfcf320d1e53b2ee985482af5cee63582b26aa6f3969f2d83e6ffb9503712f5d1a865c849c4b2111f7fd4349cefb158874d8faa323e4e7d73bf547a26f3a93
+DIST sphinx-gallery-0.9.0.tar.gz 6530860 BLAKE2B 925a745a9bedaa98cf03fbd66bdb87e5c147543a21944d827f738ea1a8bc657a01f0eba2fa5abe64f7bd3632bef604d9490740f2b6fe5100bba92aeb93f3eaf3 SHA512 e511100c5add06de681b0682c90b3e914d49625c63391896dfdec8e6f6f378cfc65fc3425d4216ee0ebbdd4feb3397517ca40a838947b31257654fff2b8a7e8a
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.9.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.9.0.ebuild
new file mode 100644
index 000000000000..c9856aaf5382
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://sphinx-gallery.github.io/
+ https://github.com/sphinx-gallery/sphinx-gallery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=sphinx_gallery::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local deselect=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}