summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-17 08:24:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-17 09:03:39 +0200
commitf91a27a8a1c2f846aa69bd269c30e73fc17e3a3e (patch)
treebbed5e5d64cff9859554fe45074d0d4b93d29fd6 /dev-python
parentdev-python/openstacksdk: Bump to 0.58.0 (diff)
downloadgentoo-f91a27a8a1c2f846aa69bd269c30e73fc17e3a3e.tar.gz
gentoo-f91a27a8a1c2f846aa69bd269c30e73fc17e3a3e.tar.bz2
gentoo-f91a27a8a1c2f846aa69bd269c30e73fc17e3a3e.zip
dev-python/pybind11: Bump to 2.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.7.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index e7e23b91ac17..10741eb8b39c 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,2 +1,3 @@
DIST pybind11-2.6.1.tar.gz 634179 BLAKE2B 33f057e88e45985a0475783b8931ec669a16efcad5d66ecb265744155e9941b2d618391a36bff1d8c1c2d74a7e0b41de50b26eae689215d4585542fbd4282cc1 SHA512 8730efec82eef8dc09a58ca3e3b28fca45880cef85d32aa5524a8fe64e23d5f6dff4ca1b48b3034a287199bd56f4db4d6806c5358bef66fde84ed0fbf80ec264
DIST pybind11-2.6.2.tar.gz 647954 BLAKE2B e336d626d314538123a121d48998b15d9d16b80a6a513e85b4ef2b3179f73732ef23b85ab91d815f15c31f7e2c5091192e90b9ff8e727725882963a895367612 SHA512 1eb346ff6b8f827053265340925e2c8038b1e2a89c352fc09f15ebe86128e7ba1f48c4368b193941f034b30bee7f72a94343e05d4841fdbbd0e4d91ed3d32025
+DIST pybind11-2.7.0.tar.gz 666200 BLAKE2B 4f78493ecbea5068dd9ab6771c9b33859baf3e14a82a6a3b361a11620ce6495763f94acca0c0a9512fa92343fa2ff91fa3e2ff7f30731bdda823b2b3fc139302 SHA512 529596c8762f463868f942ca9c4d3e4ed141bc09c734defeeace2b0250234c3359ef1f231997389fbffca849e01ba1feb8d7edc385745b6d964771aa67ced720
diff --git a/dev-python/pybind11/pybind11-2.7.0.ebuild b/dev-python/pybind11/pybind11-2.7.0.ebuild
new file mode 100644
index 000000000000..b477308fbbe4
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.7.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..10} )
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
+SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}