summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-01 20:58:13 +0200
committerMatt Turner <mattst88@gentoo.org>2020-07-16 21:13:52 -0700
commitf9c2c228814b6f75832727ca6d6dbd7bbfe082a2 (patch)
treea8917d074d57ffde1aefb9af8073ba12898eadfa /dev-python
parentdev-python/rope: vers bump, add py3_8 rem py3_6 (diff)
downloadgentoo-f9c2c228814b6f75832727ca6d6dbd7bbfe082a2.tar.gz
gentoo-f9c2c228814b6f75832727ca6d6dbd7bbfe082a2.tar.bz2
gentoo-f9c2c228814b6f75832727ca6d6dbd7bbfe082a2.zip
dev-python/pydocstyle: add py3_8, rem py3_6
py3_9 still missing on deps (too many for me bump atm) Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydocstyle/pydocstyle-5.0.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pydocstyle/pydocstyle-5.0.2-r1.ebuild b/dev-python/pydocstyle/pydocstyle-5.0.2-r1.ebuild
new file mode 100644
index 000000000000..1887ba0bb246
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-5.0.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+# Requires network to lookup github issues
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+src_prepare() {
+ default
+
+ # These tests call pip.
+ # pip install fails because we are not allowed to do that inside an ebuild.
+ rm "${S}/src/tests/test_integration.py" || die
+}