summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-12 20:12:13 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-12 21:00:31 -0700
commitf9e85cb4ae73f74e8f173c9b4daf8ac07428f34e (patch)
tree9f7549b5128be4c4512c23b57c9b67a7b67a8941 /dev-python
parentnet-analyzer/openbsd-netcat: version bump. (diff)
downloadgentoo-f9e85cb4ae73f74e8f173c9b4daf8ac07428f34e.tar.gz
gentoo-f9e85cb4ae73f74e8f173c9b4daf8ac07428f34e.tar.bz2
gentoo-f9e85cb4ae73f74e8f173c9b4daf8ac07428f34e.zip
dev-python/uritemplate-3.0.1-r1: revbump, EAPI=7, py38, enable tests
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild b/dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..250a5e8d801c
--- /dev/null
+++ b/dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="https://pypi.org/project/uritemplate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.3
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest