summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-04-19 22:22:57 -0700
committerZac Medico <zmedico@gentoo.org>2017-04-20 02:20:07 -0700
commitfa47822a43566361d1b9475e605ee24abcb5780e (patch)
treece6317fc10a7a650afc6733eae958b37862af32a /dev-python
parentdev-python/pytest-aiohttp: Add python3_6 to PYTHON_COMPAT (diff)
downloadgentoo-fa47822a43566361d1b9475e605ee24abcb5780e.tar.gz
gentoo-fa47822a43566361d1b9475e605ee24abcb5780e.tar.bz2
gentoo-fa47822a43566361d1b9475e605ee24abcb5780e.zip
dev-python/async_timeout: version bump to 1.2.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/async_timeout/Manifest1
-rw-r--r--dev-python/async_timeout/async_timeout-1.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/async_timeout/Manifest b/dev-python/async_timeout/Manifest
index 5d8e0a44067e..740ea4d50789 100644
--- a/dev-python/async_timeout/Manifest
+++ b/dev-python/async_timeout/Manifest
@@ -1,2 +1,3 @@
DIST async-timeout-1.1.0.tar.gz 7590 SHA256 b88bd1fe001b800ec23c7bf27a81b32819e2a56668e9fba5646a7f3618143081 SHA512 7132b0616052623c17d7a541051f3e759f8dc87f9ff1730585a1010bc6e139c24d5b8835431749d695fde56fb465f22094ec3f98f5f95b0b7664ec9e1f990cac WHIRLPOOL d629fb4f0bf85b5d9123ffc364da058dbeb67c07c63071fa12a57f926a8735bdbff52c4146fe16934adc60dd560e080a2e9bf39478651a2ca078b5db66802c73
+DIST async-timeout-1.2.0.tar.gz 7700 SHA256 0652d108c0156ae5ac94d99f53a6bdd039b0c076346ff8f58c9a1551fac17a19 SHA512 81a8d3fd8a6756335ce7ea292afd0ba508ea120482dfc4526017dbf6ee809e6828818653be25dee123e8626fc89cc49cfbcff41748ec950b8797b2bb21f262db WHIRLPOOL d68180af72dbd2d70de77796183a55f78aeb4e96a183bc115f68cfc5b40baa7924a117c6f3245fef6998f24e968466519f04596d4a2a4de419935fedbabb9d35
DIST async_timeout-1.0.0.tar.gz 7554 SHA256 c7afd7355b93fca0aecc15811aa53eea57f6fd7307b5bff2336b01419ebeda36 SHA512 b02fa2f9558d23e6e1cc076f8d144dcfee7adeaad67c023ce747c99935c2809e2a2223f72b0a12274f11bacadc9b69a6bc3a2914c305ef05d483dc29908e9c97 WHIRLPOOL 4f2fb79330827e17acfb141fcc846207cfee303321367921e08d5c1da7a5e0ce496774e92ac81b84b7d773eb6d83c4f702c9a41d04ae0b7a2663f32d8bd1a12c
diff --git a/dev-python/async_timeout/async_timeout-1.2.0.ebuild b/dev-python/async_timeout/async_timeout-1.2.0.ebuild
new file mode 100644
index 000000000000..6785e3411e4c
--- /dev/null
+++ b/dev-python/async_timeout/async_timeout-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_P=${PN/_/-}-${PV}
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="https://github.com/aio-libs/async_timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-aiohttp[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test || die
+}