summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-26 08:40:08 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-26 10:41:13 +0100
commitfab1838a17834fdba41b00f1082e8c3654cc0d38 (patch)
treebb8e1e5e9b8f0f103aaf9531e3e7f4c6c705b485 /dev-python
parentmedia-sound/umurmur: Removed old (diff)
downloadgentoo-fab1838a17834fdba41b00f1082e8c3654cc0d38.tar.gz
gentoo-fab1838a17834fdba41b00f1082e8c3654cc0d38.tar.bz2
gentoo-fab1838a17834fdba41b00f1082e8c3654cc0d38.zip
dev-python/botocore: Bump to 1.20.38
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.38.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index a73658dc80b7..963fcb3cfa36 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -20,4 +20,5 @@ DIST botocore-1.20.33.tar.gz 7543656 BLAKE2B eefd7b06c5a43780982616cfd640c6a1c5d
DIST botocore-1.20.34.tar.gz 7545620 BLAKE2B 49f44aa2b4799ddf03adeb48790bcf23744a13e61cc1a64be67bfadf54a51213b99ae4cf26cdfc948482b7ffeff391a06f34eb4628bf2cbf6d8af1adb78f1932 SHA512 b85878eb36507687171136fd6d8b2d00a9a9fe0123d36b42906026ff3bad3580b0e6e6e8ee50c35f14a237acf9f354c6ecdfe38b14cce83fd65fa6873aa25d84
DIST botocore-1.20.35.tar.gz 7547346 BLAKE2B 7fb58d475e8e57501346916759f4e0801f7c0ff61a60a1ffded2ff16cab6ef67d72f40169990673f294fe54bcd99eedd0ad4e2cf1fba39a237a17925d6c0f123 SHA512 b5fa8478ef7849951339ccc6d06948fd4e654deea5668eb0fd82813f3c095af8d67ad0986aa630e3cf579a1f2442100481e7a69ba7933e73b9178a1c599b05f0
DIST botocore-1.20.36.tar.gz 7548154 BLAKE2B 6e96c80320cd782978b44086e02af13496ed4969c535e523552fde41dada5f21990f0eb5060cfbd229ab0524a862c547c32fb3ea5c860b69fd11ef11f94bca49 SHA512 970f40e3c9b8b8a97dfeb4e5add80758d9f63b7ffd3e757903830d3458d635fc38e44f8f497fb99c65a407c56ed4f96ea1a32f794fbcfd490ba45747148d4cea
+DIST botocore-1.20.38.tar.gz 7557920 BLAKE2B 9912f48f334a76e5dd9a4ddd7f79a4e1a958bfd6cbc4ebf66ff257882b49a27be28114747479148317caeba1198c486771f23f0953d8c2840b9b108c69258cec SHA512 ed068e799314881dfbd40c1e100e7572b70d302c6b694f0759f151e0acc643dde7cdcc3e3345e2607637761595fc5fc9162a2d931d8d8dfbcac02f6421953e28
DIST botocore-1.20.7.tar.gz 7458254 BLAKE2B 8b9a1edda73e2564d3a3d67c6b3542d1ec9372403cb4d88396e58dfbcb5987821f278f2757e079e1ab32e03243ed3a6d1023ecc591b965512b3af5e2d43ea7b0 SHA512 9b023a31be866a50b94017a28aca40b5fe2e720959c928a3fd93db96041f3886049717f50461222a09572c0c56c5961a4614b80e400e4fa6d8b3ff4b4ab681df
diff --git a/dev-python/botocore/botocore-1.20.38.ebuild b/dev-python/botocore/botocore-1.20.38.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.38.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}