summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-21 10:47:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-21 10:55:36 -0500
commitfb353aefadde9f6ba45281f1f063548dec5ffbf5 (patch)
tree74b93d4971198b204ae84f1e3baec4d57e717bd8 /dev-python
parentdev-db/etcd: remove old versions (diff)
downloadgentoo-fb353aefadde9f6ba45281f1f063548dec5ffbf5.tar.gz
gentoo-fb353aefadde9f6ba45281f1f063548dec5ffbf5.tar.bz2
gentoo-fb353aefadde9f6ba45281f1f063548dec5ffbf5.zip
dev-python/notify2: adding for pulseaudio-dlna
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/notify2/Manifest1
-rw-r--r--dev-python/notify2/metadata.xml13
-rw-r--r--dev-python/notify2/notify2-0.3.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/notify2/Manifest b/dev-python/notify2/Manifest
new file mode 100644
index 000000000000..050a18e7734d
--- /dev/null
+++ b/dev-python/notify2/Manifest
@@ -0,0 +1 @@
+DIST notify2-0.3.tar.gz 8798 SHA256 684281f91c51fc60bc7909a35bd21d043a2a421f4e269de1ed1f13845d1d6321 SHA512 3290a5ff291d5500bcf631094fcf10302b234353eb8c26b91e7cd264238443866aadc15224d51eb6608e16b7ffbc9316d4bc551e5ad9de2a48b12a31b195739f WHIRLPOOL f28d569baafecaad0b2bf42856c67371ac42660dd6259a91b1d06bbcd0da15c0cfe0a87d72c2171cc23f01cacb104b633c4c386178760441ebcc8c58b32407f9
diff --git a/dev-python/notify2/metadata.xml b/dev-python/notify2/metadata.xml
new file mode 100644
index 000000000000..5727453189bc
--- /dev/null
+++ b/dev-python/notify2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/notify2/notify2-0.3.ebuild b/dev-python/notify2/notify2-0.3.ebuild
new file mode 100644
index 000000000000..cb20f99de526
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to DBus notifications."
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ distutils-r1_python_install_all
+}