summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-20 10:56:52 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-20 10:56:52 +0100
commitfbdddea5b0803b49fd2c64cbbd6cb4688beeb59e (patch)
treeddc619bc6636694becec7d6d5f44952ca3058c0d /dev-python
parentdev-python/polygon: Replace distutils-r1 EXAMPLES use (diff)
downloadgentoo-fbdddea5b0803b49fd2c64cbbd6cb4688beeb59e.tar.gz
gentoo-fbdddea5b0803b49fd2c64cbbd6cb4688beeb59e.tar.bz2
gentoo-fbdddea5b0803b49fd2c64cbbd6cb4688beeb59e.zip
dev-python/pyalsaaudio: Replace distutils-r1 EXAMPLES use
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild8
-rw-r--r--dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild6
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild b/dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild
index 687e556b8ed5..cc8e0a892d3b 100644
--- a/dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild
+++ b/dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -32,7 +32,11 @@ python_compile_all() {
python_install_all() {
use doc && local HTML_DOCS=( doc/html/. )
- local EXAMPLES=( *test.py )
+ if use examples; then
+ docinto examples
+ dodoc *test.py
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
distutils-r1_python_install_all
}
diff --git a/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild b/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
index 86ab4f4bfb56..755668b93831 100644
--- a/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
+++ b/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
@@ -39,7 +39,11 @@ python_test() {
python_install_all() {
use doc && local HTML_DOCS=( doc/html/. )
- local EXAMPLES=( *test.py )
+ if use examples; then
+ docinto examples
+ dodoc *test.py
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
distutils-r1_python_install_all
}