summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-17 18:56:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 11:09:21 +0300
commitfc9c0547b768dde4e6cd35f14bd9b965e5a7a7aa (patch)
tree33ed4d9fa80dcae09eaff738a10ccc2f9a9eb279 /dev-python
parentdev-python/pydata-sphinx-theme: move from ::guru (diff)
downloadgentoo-fc9c0547b768dde4e6cd35f14bd9b965e5a7a7aa.tar.gz
gentoo-fc9c0547b768dde4e6cd35f14bd9b965e5a7a7aa.tar.bz2
gentoo-fc9c0547b768dde4e6cd35f14bd9b965e5a7a7aa.zip
dev-python/pytest-ordering: move from ::guru
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-ordering/Manifest1
-rw-r--r--dev-python/pytest-ordering/metadata.xml17
-rw-r--r--dev-python/pytest-ordering/pytest-ordering-0.6.ebuild34
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytest-ordering/Manifest b/dev-python/pytest-ordering/Manifest
new file mode 100644
index 000000000000..0036ecd18b92
--- /dev/null
+++ b/dev-python/pytest-ordering/Manifest
@@ -0,0 +1 @@
+DIST pytest-ordering-0.6.tar.gz 11046 BLAKE2B 468ae5f04029b96ed3058b7f429aec0aaf96092453b229c3de5eab174702af2c1a9fe83171c68d282c4a144b3dd736daf9ed87b9e139a7bd175114f504049ebc SHA512 fd3aec83914f64d1295e1a1bf3fdc580c6824a749a1da8cebae275fef940d6ed6e5dcafad321d94f504a153e13e298b6544dc3c2db716a6b25d3148c2365fe15
diff --git a/dev-python/pytest-ordering/metadata.xml b/dev-python/pytest-ordering/metadata.xml
new file mode 100644
index 000000000000..48b39a119114
--- /dev/null
+++ b/dev-python/pytest-ordering/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">https://github.com/ftobia/pytest-ordering</remote-id>
+ <remote-id type="pypi">pytest-ordering</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
new file mode 100644
index 000000000000..a6fe80e2943f
--- /dev/null
+++ b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to run your tests in a specific order"
+HOMEPAGE="
+ https://github.com/ftobia/pytest-ordering
+ https://pypi.org/project/pytest-ordering
+"
+SRC_URI="https://github.com/ftobia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? ( dev-python/pytest-ordering[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source
+
+python_prepare_all() {
+ # TypeError: `args` parameter expected to be a list or tuple of strings, got: '--markers' (type: <class 'str'>)
+ sed -i -e 's:test_run_marker_registered:_&:' \
+ tests/test_ordering.py || die
+
+ distutils-r1_python_prepare_all
+}