summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-30 22:20:49 +0000
committerSam James <sam@gentoo.org>2022-06-30 22:20:58 +0000
commitfca437485e58a32d6d3ece361d8a528f00aa8d82 (patch)
tree6aeedac44c9499b49ea0fa492aba6bcaef56c1b4 /dev-python
parentdev-qt/qtxmlpatterns: Stabilize 5.15.5 amd64, #853232 (diff)
downloadgentoo-fca437485e58a32d6d3ece361d8a528f00aa8d82.tar.gz
gentoo-fca437485e58a32d6d3ece361d8a528f00aa8d82.tar.bz2
gentoo-fca437485e58a32d6d3ece361d8a528f00aa8d82.zip
dev-python/pypam: treeclean
Bug: https://bugs.gentoo.org/802927 Bug: https://bugs.gentoo.org/833297 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypam/Manifest1
-rw-r--r--dev-python/pypam/files/PyPAM-0.5.0-dealloc.patch17
-rw-r--r--dev-python/pypam/files/PyPAM-0.5.0-memory-errors.patch128
-rw-r--r--dev-python/pypam/files/PyPAM-0.5.0-nofree.patch60
-rw-r--r--dev-python/pypam/files/PyPAM-0.5.0-return-value.patch57
-rw-r--r--dev-python/pypam/files/PyPAM-python3-support.patch198
-rw-r--r--dev-python/pypam/files/pypam-0.5.0-stricter.patch15
-rw-r--r--dev-python/pypam/metadata.xml5
-rw-r--r--dev-python/pypam/pypam-0.5.0-r6.ebuild45
-rw-r--r--dev-python/pypam/pypam-0.5.0-r7.ebuild45
-rw-r--r--dev-python/pypam/pypam-0.5.0-r8.ebuild40
11 files changed, 0 insertions, 611 deletions
diff --git a/dev-python/pypam/Manifest b/dev-python/pypam/Manifest
deleted file mode 100644
index 01642e48981b..000000000000
--- a/dev-python/pypam/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST PyPAM-0.5.0.tar.gz 105206 BLAKE2B 7778275cae11606ca8e522d2f99fb0558c55545cdaedb3ff7c55b4bb693ed3429e22566912f53c7795f73316bc45f1bfbdf5a53daec234dba87e1c141e2410f2 SHA512 9e0e919e34930d2283307cd6665c5287c664a76a5de56367bd975867ac26b376ae03d30cb3bc4a16390c977ca2690cfd2e90ac73dcc7886b8c999444da4a07e0
diff --git a/dev-python/pypam/files/PyPAM-0.5.0-dealloc.patch b/dev-python/pypam/files/PyPAM-0.5.0-dealloc.patch
deleted file mode 100644
index 596491c46bcd..000000000000
--- a/dev-python/pypam/files/PyPAM-0.5.0-dealloc.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -up a/PAMmodule.c b/PAMmodule.c
---- a/PAMmodule.c
-+++ b/PAMmodule.c
-@@ -538,10 +538,11 @@ static void PyPAM_dealloc(PyPAMObject *s
- free(self->service);
- free(self->user);
- free(self->conv);
-- pam_end(self->pamh, PAM_SUCCESS);
-+ if (self->pamh)
-+ pam_end(self->pamh, PAM_SUCCESS);
- dlclose(self->dlh2);
- dlclose(self->dlh1);
-- PyMem_DEL(self);
-+ PyObject_Del(self);
- }
-
- static PyObject * PyPAM_getattr(PyPAMObject *self, char *name)
diff --git a/dev-python/pypam/files/PyPAM-0.5.0-memory-errors.patch b/dev-python/pypam/files/PyPAM-0.5.0-memory-errors.patch
deleted file mode 100644
index 6da3dd6eb7d6..000000000000
--- a/dev-python/pypam/files/PyPAM-0.5.0-memory-errors.patch
+++ /dev/null
@@ -1,128 +0,0 @@
-diff -up a/PAMmodule.c b/PAMmodule.c
---- a/PAMmodule.c
-+++ b/PAMmodule.c
-@@ -37,33 +37,48 @@ static void PyPAM_Err(PyPAMObject *self,
-
- err_msg = pam_strerror(self->pamh, result);
- error = Py_BuildValue("(si)", err_msg, result);
-- Py_INCREF(PyPAM_Error);
- PyErr_SetObject(PyPAM_Error, error);
-+ Py_XDECREF(error);
- }
-
- static int PyPAM_conv(int num_msg, const struct pam_message **msg,
- struct pam_response **resp, void *appdata_ptr)
- {
-- PyObject *args;
--
-+ PyObject *args, *msgList, *respList, *item;
-+ struct pam_response *response, *spr;
- PyPAMObject* self = (PyPAMObject *) appdata_ptr;
-+
- if (self->callback == NULL)
- return PAM_CONV_ERR;
-
- Py_INCREF(self);
-
-- PyObject* msgList = PyList_New(num_msg);
--
-+ msgList = PyList_New(num_msg);
-+ if (msgList == NULL) {
-+ Py_DECREF(self);
-+ return PAM_CONV_ERR;
-+ }
-+
- for (int i = 0; i < num_msg; i++) {
-- PyList_SetItem(msgList, i,
-- Py_BuildValue("(si)", msg[i]->msg, msg[i]->msg_style));
-+ item = Py_BuildValue("(si)", msg[i]->msg, msg[i]->msg_style);
-+ if (item == NULL) {
-+ Py_DECREF(msgList);
-+ Py_DECREF(self);
-+ return PAM_CONV_ERR;
-+ }
-+ PyList_SetItem(msgList, i, item);
- }
--
-+
- args = Py_BuildValue("(OO)", self, msgList);
-- PyObject* respList = PyEval_CallObject(self->callback, args);
-+ if (args == NULL) {
-+ Py_DECREF(self);
-+ Py_DECREF(msgList);
-+ return PAM_CONV_ERR;
-+ }
-+ respList = PyEval_CallObject(self->callback, args);
- Py_DECREF(args);
- Py_DECREF(self);
--
-+
- if (respList == NULL)
- return PAM_CONV_ERR;
-
-@@ -71,11 +86,15 @@ static int PyPAM_conv(int num_msg, const
- Py_DECREF(respList);
- return PAM_CONV_ERR;
- }
--
-- *resp = (struct pam_response *) malloc(
-+
-+ response = (struct pam_response *) malloc(
- PyList_Size(respList) * sizeof(struct pam_response));
-+ if (response == NULL) {
-+ Py_DECREF(respList);
-+ return PAM_CONV_ERR;
-+ }
-+ spr = response;
-
-- struct pam_response* spr = *resp;
- for (int i = 0; i < PyList_Size(respList); i++, spr++) {
- PyObject* respTuple = PyList_GetItem(respList, i);
- char* resp_text;
-@@ -85,7 +104,7 @@ static int PyPAM_conv(int num_msg, const
- free((--spr)->resp);
- --i;
- }
-- free(*resp);
-+ free(response);
- Py_DECREF(respList);
- return PAM_CONV_ERR;
- }
-@@ -95,7 +114,8 @@ static int PyPAM_conv(int num_msg, const
- }
-
- Py_DECREF(respList);
--
-+ *resp = response;
-+
- return PAM_SUCCESS;
- }
-
-@@ -122,7 +142,11 @@ static PyObject * PyPAM_pam(PyObject *se
- PyPAMObject_Type.ob_type = &PyType_Type;
- p = (PyPAMObject *) PyObject_NEW(PyPAMObject, &PyPAMObject_Type);
-
-+ if (p == NULL)
-+ return NULL;
-+
- if ((spc = (struct pam_conv *) malloc(sizeof(struct pam_conv))) == NULL) {
-+ Py_DECREF((PyObject *)p);
- PyErr_SetString(PyExc_MemoryError, "out of memory");
- return NULL;
- }
-@@ -455,9 +479,15 @@ static PyObject * PyPAM_getenvlist(PyObj
- }
-
- retval = PyList_New(0);
-+ if (retval == NULL)
-+ return NULL;
-
- while ((cp = *(result++)) != NULL) {
- entry = Py_BuildValue("s", cp);
-+ if (entry == NULL) {
-+ Py_DECREF(retval);
-+ return NULL;
-+ }
- PyList_Append(retval, entry);
- Py_DECREF(entry);
- }
diff --git a/dev-python/pypam/files/PyPAM-0.5.0-nofree.patch b/dev-python/pypam/files/PyPAM-0.5.0-nofree.patch
deleted file mode 100644
index f27e9d543d06..000000000000
--- a/dev-python/pypam/files/PyPAM-0.5.0-nofree.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff --git a/PAMmodule.c b/PAMmodule.c
-index 03cb799..a7ff8a5 100644
---- a/PAMmodule.c
-+++ b/PAMmodule.c
-@@ -24,8 +24,6 @@ typedef struct {
- char *service;
- char *user;
- PyObject *callback;
-- struct pam_response *response_data;
-- int response_len;
- PyObject *user_data;
- void *dlh1, *dlh2;
- } PyPAMObject;
-@@ -54,15 +52,6 @@ static int PyPAM_conv(int num_msg, const struct pam_message **msg,
-
- Py_INCREF(self);
-
-- if (NULL != self->response_data) {
-- for (int i = 0; i < self->response_len; i++) {
-- free(self->response_data[0].resp);
-- }
-- free(self->response_data);
-- self->response_data = NULL;
-- self->response_len = 0;
-- }
--
- PyObject* msgList = PyList_New(num_msg);
-
- for (int i = 0; i < num_msg; i++) {
-@@ -92,6 +81,10 @@ static int PyPAM_conv(int num_msg, const struct pam_message **msg,
- char* resp_text;
- int resp_retcode = 0;
- if (!PyArg_ParseTuple(respTuple, "si", &resp_text, &resp_retcode)) {
-+ while (i > 0) {
-+ free((--spr)->resp);
-+ --i;
-+ }
- free(*resp);
- Py_DECREF(respList);
- return PAM_CONV_ERR;
-@@ -100,10 +93,6 @@ static int PyPAM_conv(int num_msg, const struct pam_message **msg,
- spr->resp_retcode = resp_retcode;
- Py_DECREF(respTuple);
- }
--
-- // Save this so we can free it later.
-- self->response_data = *resp;
-- self->response_len = PyList_Size(respList);
-
- Py_DECREF(respList);
-
-@@ -144,8 +133,6 @@ static PyObject * PyPAM_pam(PyObject *self, PyObject *args)
- p->user = NULL;
- Py_INCREF(Py_None);
- p->callback = Py_None;
-- p->response_data = NULL;
-- p->response_len = 0;
- Py_INCREF(Py_None);
- p->user_data = Py_None;
-
diff --git a/dev-python/pypam/files/PyPAM-0.5.0-return-value.patch b/dev-python/pypam/files/PyPAM-0.5.0-return-value.patch
deleted file mode 100644
index 3773d6fafd20..000000000000
--- a/dev-python/pypam/files/PyPAM-0.5.0-return-value.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff -up a/PAMmodule.c b/PAMmodule.c
---- a/PAMmodule.c
-+++ b/PAMmodule.c
-@@ -248,7 +248,7 @@ static PyObject * PyPAM_setcred(PyObject
- result = pam_setcred(_self->pamh, flags);
-
- if (result != PAM_SUCCESS) {
-- PyErr_SetString(PyPAM_Error, "Not authenticated");
-+ PyPAM_Err(_self, result);
- return NULL;
- }
-
-@@ -270,7 +270,7 @@ static PyObject * PyPAM_acct_mgmt(PyObje
- result = pam_acct_mgmt(_self->pamh, flags);
-
- if (result != PAM_SUCCESS) {
-- PyErr_SetString(PyPAM_Error, "Not authenticated");
-+ PyPAM_Err(_self, result);
- return NULL;
- }
-
-@@ -292,7 +292,7 @@ static PyObject * PyPAM_chauthtok(PyObje
- result = pam_chauthtok(_self->pamh, flags);
-
- if (result != PAM_SUCCESS) {
-- PyErr_SetString(PyPAM_Error, "Not authenticated");
-+ PyPAM_Err(_self, result);
- return NULL;
- }
-
-@@ -314,7 +314,7 @@ static PyObject * PyPAM_open_session(PyO
- result = pam_open_session(_self->pamh, flags);
-
- if (result != PAM_SUCCESS) {
-- PyErr_SetString(PyPAM_Error, "Not authenticated");
-+ PyPAM_Err(_self, result);
- return NULL;
- }
-
-@@ -336,7 +336,7 @@ static PyObject * PyPAM_close_session(Py
- result = pam_close_session(_self->pamh, flags);
-
- if (result != PAM_SUCCESS) {
-- PyErr_SetString(PyPAM_Error, "Not authenticated");
-+ PyPAM_Err(_self, result);
- return NULL;
- }
-
-@@ -433,7 +433,7 @@ static PyObject * PyPAM_putenv(PyObject
- result = pam_putenv(_self->pamh, val);
-
- if (result != PAM_SUCCESS) {
-- PyErr_SetString(PyPAM_Error, "Not authenticated");
-+ PyPAM_Err(_self, result);
- return NULL;
- }
-
diff --git a/dev-python/pypam/files/PyPAM-python3-support.patch b/dev-python/pypam/files/PyPAM-python3-support.patch
deleted file mode 100644
index a4100953631f..000000000000
--- a/dev-python/pypam/files/PyPAM-python3-support.patch
+++ /dev/null
@@ -1,198 +0,0 @@
---- a/PAMmodule.c
-+++ b(PAMmodule.c
-@@ -15,6 +15,14 @@
- #include <stdio.h>
- #include <dlfcn.h>
-
-+#if PY_MAJOR_VERSION >= 3
-+#define IS_PY3K
-+#else
-+// include bytesobject.h to map PyBytes_* to PyString_*
-+#include <bytesobject.h>
-+#endif
-+
-+
- static PyObject *PyPAM_Error;
-
- typedef struct {
-@@ -28,7 +36,11 @@
- void *dlh1, *dlh2;
- } PyPAMObject;
-
-+#ifdef IS_PY3K
-+static PyTypeObject PyPAMObject_Type;
-+#else
- staticforward PyTypeObject PyPAMObject_Type;
-+#endif
-
- static void PyPAM_Err(PyPAMObject *self, int result)
- {
-@@ -139,7 +151,6 @@
- return NULL;
- }
-
-- PyPAMObject_Type.ob_type = &PyType_Type;
- p = (PyPAMObject *) PyObject_NEW(PyPAMObject, &PyPAMObject_Type);
-
- if (p == NULL)
-@@ -562,35 +573,44 @@
- PyObject_Del(self);
- }
-
--static PyObject * PyPAM_getattr(PyPAMObject *self, char *name)
--{
-- return Py_FindMethod(PyPAMObject_Methods, (PyObject *) self, name);
--}
--
- static PyObject * PyPAM_repr(PyPAMObject *self)
- {
- char buf[1024];
-
- snprintf(buf, 1024, "<pam object, service=\"%s\", user=\"%s\", conv=%p, pamh=%p>",
- self->service, self->user, self->conv, self->pamh);
-- return PyString_FromString(buf);
-+ return PyBytes_FromString(buf);
- }
-
- static PyTypeObject PyPAMObject_Type = {
-- PyObject_HEAD_INIT(0) /* Must fill in type value later */
-- 0,
-- "pam",
-- sizeof(PyPAMObject),
-- 0,
-- (destructor)PyPAM_dealloc, /*tp_dealloc*/
-- 0, /*tp_print*/
-- (getattrfunc)PyPAM_getattr, /*tp_getattr*/
-- 0, /*tp_setattr*/
-- 0, /*tp_compare*/
-- (reprfunc)PyPAM_repr, /*tp_repr*/
-- 0, /*tp_as_number*/
-- 0, /*tp_as_sequence*/
-- 0, /*tp_as_mapping*/
-+ PyVarObject_HEAD_INIT(NULL, 0) /* Must fill in type value later */
-+ "pam", /* tp_name */
-+ sizeof(PyPAMObject), /* tp_basicsize */
-+ 0, /* tp_itemsize */
-+ (destructor)PyPAM_dealloc, /* tp_dealloc */
-+ 0, /* tp_print */
-+ 0, /* tp_getattr */
-+ 0, /* tp_setattr */
-+ 0, /* tp_compare */
-+ (reprfunc)PyPAM_repr, /* tp_repr */
-+ 0, /* tp_as_number */
-+ 0, /* tp_as_sequence */
-+ 0, /* tp_as_mapping */
-+ 0, /* tp_hash */
-+ 0, /* tp_call */
-+ 0, /* tp_str */
-+ PyObject_GenericGetAttr, /* tp_getattro */
-+ 0, /* tp_setattro */
-+ 0, /* tp_as_buffer */
-+ Py_TPFLAGS_DEFAULT, /* tp_flags */
-+ "PyPAM", /* tp_doc */
-+ 0, /* tp_traverse */
-+ 0, /* tp_clear */
-+ 0, /* tp_richcompare */
-+ 0, /* tp_weaklistoffset */
-+ 0, /* tp_iter */
-+ 0, /* tp_iternext */
-+ PyPAMObject_Methods, /* tp_methods */
- };
-
- static PyMethodDef PyPAM_Methods[] = {
-@@ -607,7 +627,12 @@
- */
- static void insint(PyObject *d, char *name, int value)
- {
-- PyObject* v = PyInt_FromLong((long) value);
-+ PyObject* v;
-+#ifdef IS_PY3K
-+ v = PyLong_FromLong((long) value);
-+#else
-+ v = PyInt_FromLong((long) value);
-+#endif
-
- if (!v || PyDict_SetItemString(d, name, v))
- PyErr_Clear();
-@@ -615,19 +640,42 @@
- Py_XDECREF(v);
- }
-
-+#ifdef IS_PY3K
-+static struct PyModuleDef pamdef = {
-+ PyModuleDef_HEAD_INIT,
-+ "PAM",
-+ NULL,
-+ -1,
-+ PyPAM_Methods,
-+ NULL,
-+ NULL,
-+ NULL,
-+ NULL
-+};
-+
-+#define INITERROR return NULL
-+PyObject *PyInit_PAM(void)
-+
-+#else
-+#define INITERROR return
- void initPAM(void)
-+#endif
- {
- PyObject *m, *d;
-
-+#ifdef IS_PY3K
-+ m = PyModule_Create(&pamdef);
-+#else
- m = Py_InitModule("PAM", PyPAM_Methods);
-+#endif
- d = PyModule_GetDict(m);
-
- PyPAM_Error = PyErr_NewException("PAM.error", NULL, NULL);
- if (PyPAM_Error == NULL)
-- return;
-+ INITERROR;
- PyDict_SetItemString(d, "error", PyPAM_Error);
-
-- PyPAMObject_Type.ob_type = &PyType_Type;
-+ Py_TYPE(&PyPAMObject_Type) = &PyType_Type;
- PyPAMObject_Type.tp_doc = PyPAMObject_doc;
- Py_INCREF(&PyPAMObject_Type);
-
-@@ -692,4 +740,7 @@
- insint(d, "PAM_BINARY_PROMPT", PAM_BINARY_PROMPT);
- #endif
-
-+#ifdef IS_PY3K
-+ return m;
-+#endif
- }
---- a/setup.py
-+++ b/setup.py
-@@ -12,7 +12,7 @@
- license='LGPL',
- ext_modules=[
- Extension(
-- 'PAMmodule',
-+ 'PAM',
- ['PAMmodule.c'],
- libraries=['pam', 'pam_misc'],
- extra_compile_args = ['-std=c99'],
---- a/tests/PamTest.py
-+++ b/tests/PamTest.py
-@@ -41,13 +41,13 @@
- def test_userdata_default(self):
- """The default value for userdata is None."""
-
-- self.failUnless(self.pam.get_userdata() is None)
-+ self.assertTrue(self.pam.get_userdata() is None)
-
- def test_userdata(self):
- """The userdata getter and setter will store and return any data."""
-
- self.pam.set_userdata(1)
-- self.failUnless(self.pam.get_userdata() == 1)
-+ self.assertTrue(self.pam.get_userdata() == 1)
-
- def test_start(self):
- """pam.start() works as expected."""
diff --git a/dev-python/pypam/files/pypam-0.5.0-stricter.patch b/dev-python/pypam/files/pypam-0.5.0-stricter.patch
deleted file mode 100644
index 2ebe2d0af953..000000000000
--- a/dev-python/pypam/files/pypam-0.5.0-stricter.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-=== modified file 'PAMmodule.c'
---- a/PAMmodule.c
-+++ b/PAMmodule.c
-@@ -9,8 +9,9 @@
-
-+#include <Python.h>
- #include <security/pam_appl.h>
- #include <security/pam_misc.h>
--#include <Python.h>
- #include <stdio.h>
-+#include <string.h>
- #include <dlfcn.h>
-
- static PyObject *PyPAM_Error;
-
diff --git a/dev-python/pypam/metadata.xml b/dev-python/pypam/metadata.xml
deleted file mode 100644
index dde3e0dc4ca9..000000000000
--- a/dev-python/pypam/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!--maintainer-needed-->
-</pkgmetadata>
diff --git a/dev-python/pypam/pypam-0.5.0-r6.ebuild b/dev-python/pypam/pypam-0.5.0-r6.ebuild
deleted file mode 100644
index aebb5e349358..000000000000
--- a/dev-python/pypam/pypam-0.5.0-r6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-MY_P="PyPAM-${PV}"
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python Bindings for PAM (Pluggable Authentication Modules)"
-HOMEPAGE="http://www.pangalactic.org/PyPAM"
-SRC_URI="http://www.pangalactic.org/PyPAM/${MY_P}.tar.gz
- https://distfiles.gentoo.org/distfiles/ad/PyPAM-0.5.0.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-IUSE=""
-
-DEPEND=">=sys-libs/pam-0.64"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS examples/pamtest.py )
-
-PATCHES=(
- # Pull patches from fedora.
- "${FILESDIR}/PyPAM-${PV}-dealloc.patch"
- "${FILESDIR}/PyPAM-${PV}-nofree.patch"
- "${FILESDIR}/PyPAM-${PV}-memory-errors.patch"
- "${FILESDIR}/PyPAM-${PV}-return-value.patch"
- "${FILESDIR}/PyPAM-python3-support.patch"
- # Fix a missing include.
- "${FILESDIR}/${P}-stricter.patch"
-)
-
-src_compile() {
- append-cflags -fno-strict-aliasing
- distutils-r1_src_compile
-}
-
-python_test() {
- "${PYTHON}" tests/PamTest.py
-}
diff --git a/dev-python/pypam/pypam-0.5.0-r7.ebuild b/dev-python/pypam/pypam-0.5.0-r7.ebuild
deleted file mode 100644
index a7a3593a67d9..000000000000
--- a/dev-python/pypam/pypam-0.5.0-r7.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=no
-MY_P="PyPAM-${PV}"
-PYTHON_COMPAT=( python3_{7..10} )
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python Bindings for PAM (Pluggable Authentication Modules)"
-HOMEPAGE="http://www.pangalactic.org/PyPAM"
-SRC_URI="http://www.pangalactic.org/PyPAM/${MY_P}.tar.gz
- https://distfiles.gentoo.org/distfiles/ad/PyPAM-0.5.0.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-IUSE=""
-
-DEPEND=">=sys-libs/pam-0.64"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS examples/pamtest.py )
-
-PATCHES=(
- # Pull patches from fedora.
- "${FILESDIR}/PyPAM-${PV}-dealloc.patch"
- "${FILESDIR}/PyPAM-${PV}-nofree.patch"
- "${FILESDIR}/PyPAM-${PV}-memory-errors.patch"
- "${FILESDIR}/PyPAM-${PV}-return-value.patch"
- "${FILESDIR}/PyPAM-python3-support.patch"
- # Fix a missing include.
- "${FILESDIR}/${P}-stricter.patch"
-)
-
-src_compile() {
- append-cflags -fno-strict-aliasing
- distutils-r1_src_compile
-}
-
-python_test() {
- "${PYTHON}" tests/PamTest.py || die
-}
diff --git a/dev-python/pypam/pypam-0.5.0-r8.ebuild b/dev-python/pypam/pypam-0.5.0-r8.ebuild
deleted file mode 100644
index 9d2b524b2b96..000000000000
--- a/dev-python/pypam/pypam-0.5.0-r8.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-MY_P="PyPAM-${PV}"
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python Bindings for PAM (Pluggable Authentication Modules)"
-HOMEPAGE="http://www.pangalactic.org/PyPAM"
-SRC_URI="http://www.pangalactic.org/PyPAM/${MY_P}.tar.gz
- https://distfiles.gentoo.org/distfiles/ad/PyPAM-0.5.0.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-IUSE=""
-
-DEPEND=">=sys-libs/pam-0.64"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS examples/pamtest.py )
-
-PATCHES=(
- # Pull patches from fedora.
- "${FILESDIR}/PyPAM-${PV}-dealloc.patch"
- "${FILESDIR}/PyPAM-${PV}-nofree.patch"
- "${FILESDIR}/PyPAM-${PV}-memory-errors.patch"
- "${FILESDIR}/PyPAM-${PV}-return-value.patch"
- "${FILESDIR}/PyPAM-python3-support.patch"
- # Fix a missing include.
- "${FILESDIR}/${P}-stricter.patch"
-)
-
-python_test() {
- "${EPYTHON}" tests/PamTest.py || die
-}