summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-24 22:46:56 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 23:09:49 +0100
commitfd18a85f7fc162af46164eeb40fc95067bc10a67 (patch)
tree630d178b9be58dd70f3a62fbec94daac3b2875bc /dev-python
parentdev-python/numpydoc: Bump to 1.2 (diff)
downloadgentoo-fd18a85f7fc162af46164eeb40fc95067bc10a67.tar.gz
gentoo-fd18a85f7fc162af46164eeb40fc95067bc10a67.tar.bz2
gentoo-fd18a85f7fc162af46164eeb40fc95067bc10a67.zip
dev-python/fonttools: Bump to 4.29.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.29.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 56b02a28dec3..279af5c95fc6 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,2 +1,3 @@
DIST fonttools-4.28.4.tar.gz 2945369 BLAKE2B f178552aca7b41dcec1c03d2a7c3de17cdb5f4b2e057a75e196e78a098b9959a038a9a3b14ee8546d5ea12e3546c22d2a8d9b34a922c0822bf52f78bc03f4f54 SHA512 9ecdf4186e24a8a44c6010432d71f1689ebf8461a404dde71259eb4712c4987d94bbe31b33ad6943fb2e0105fc9f8e9032a94e6ccbb4ac01fe330bb700a39c63
DIST fonttools-4.28.5.tar.gz 2948092 BLAKE2B b35f4be68cfc2be6afb209c2caee38f7088a1a17dea85fac0f40183b61a3eded59fab47f703587097669f8823a8dbc2e84b0df58305597784bed7f8c2e2b0f28 SHA512 5d87f4fadbcb447d1c1a1e97550f6a477d74bfe8647d14b35097e03e6a45a1a01632d2092483d675c523f97d4a04f39aa9b3175e535b1e1a4f19d619eb40ad5f
+DIST fonttools-4.29.0.tar.gz 2954211 BLAKE2B 47b7228b2f0f7332f54df58d8be8289b9bc3a737caa57ffafe9a8467e4d7e35db153f7e02caf8c6129af8dbb2bc18689af3f3122b0be7afee19bece83c846aad SHA512 0573970ceaf43e4987eee970aa93a6aba5af2b592b5d92a1aec36b102cb1967f380f8170f7a14bb80cd6348ef09737ac17a0f82eaa1ad73f9f5e246271d34b32
diff --git a/dev-python/fonttools/fonttools-4.29.0.ebuild b/dev-python/fonttools/fonttools-4.29.0.ebuild
new file mode 100644
index 000000000000..e91a05a05cd3
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.29.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx epytest Tests fontTools
+}