summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-11 16:24:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-11 16:49:29 +0200
commitff3657e8f849088698c276a807a879625d63277e (patch)
tree35511c1a8f364948bb3e6b4373e39d22c7879f9f /dev-python
parentdev-python/fastjsonschema: New package, dep of nbformat (diff)
downloadgentoo-ff3657e8f849088698c276a807a879625d63277e.tar.gz
gentoo-ff3657e8f849088698c276a807a879625d63277e.tar.bz2
gentoo-ff3657e8f849088698c276a807a879625d63277e.zip
dev-python/nbformat: Bump to 5.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.0.8.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 4fe75ef40942..441dddd0ea1f 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1 +1,2 @@
DIST nbformat-5.0.7.gh.tar.gz 125328 BLAKE2B fa048ceef9d0612052dcf3180bca4228dba5117c6b0fb642f777bbd35e2b6f868454ae3d793aa0da3904757e42309ac53be19621a62967b719da86ab37d5f052 SHA512 3c1429a232d15d023f161f41cdab3364242f1a026349ea5aaeceba6a80afba981cc512a9f148ae3a0fa856a847c4560cc95abd965cc5d088a9f89c2b61d48fd1
+DIST nbformat-5.0.8.gh.tar.gz 127329 BLAKE2B 6252d35f72fd0af5a89d83e9e48f61baf2656eb6530d4a7b05a5241e7272098992d70d68705da4fb9921ab1939378658b2e6e5f765a453f932e94e9232006a66 SHA512 956add98517f1128d8efacae1f3cf9fe27b4d7acae4a56e14dd6c2942aab39b063170759bc6de67bcedd2e0fd6c7ab1a36aef268f2088644ba31caa936b9359d
diff --git a/dev-python/nbformat/nbformat-5.0.8.ebuild b/dev-python/nbformat/nbformat-5.0.8.ebuild
new file mode 100644
index 000000000000..fe138eb0ff0a
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="https://jupyter.org"
+# missing on pypi
+SRC_URI="
+ https://github.com/jupyter/nbformat/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ test? (
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc
+distutils_enable_tests pytest