summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-19 14:10:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-19 14:24:33 +0200
commitfc6947108ba8326348e3a1e6fd95a25c5a6b9d0a (patch)
tree0b8bc0b68d8b239c1f56f9808f5038485ea2305b /dev-qt/assistant
parentqt5-build.eclass: Add _QT5_GENTOOPATCHSET_REV qtbase patchset logic (diff)
downloadgentoo-fc6947108ba8326348e3a1e6fd95a25c5a6b9d0a.tar.gz
gentoo-fc6947108ba8326348e3a1e6fd95a25c5a6b9d0a.tar.bz2
gentoo-fc6947108ba8326348e3a1e6fd95a25c5a6b9d0a.zip
dev-qt/assistant: 5.15.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/assistant')
-rw-r--r--dev-qt/assistant/Manifest1
-rw-r--r--dev-qt/assistant/assistant-5.15.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index 19abae437974..8c2a6b20b3ee 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1 +1,2 @@
DIST qttools-everywhere-opensource-src-5.15.4.tar.xz 8897256 BLAKE2B e7d8055c9b4b52b188f61c73a300275838647d95f9eb0437129482d91584bbc0705ce9360b0a8fee2775a4cfefda53bc5aae70b10ca34d1bdeb09aa19b7d13bb SHA512 26edf546a1ec7195f1ff5a9e40e430fdd0c7ebb7d86e44ed22b093426c23ff25b2c972fa520abd1064369d32609019746c2fe972a3f593c6f7539d339642f06e
+DIST qttools-everywhere-opensource-src-5.15.5.tar.xz 8898140 BLAKE2B 49b7b0db9d9ae9c6d405678eab0ec097bc160eb7787bc939aa92816cc63c5c97aef2de0c978a2a3597014878dca9466631131bc7746bd03d87229ed7edb6594c SHA512 ff5e658ec812dd36d00ad3ac7e824de708968ff1c66a73da1470b6f0cdb6853a7084f18b1bcf1614afd4c23f381d817d7eb665f8573a4e981a9b87c6e4d6fa2b
diff --git a/dev-qt/assistant/assistant-5.15.5.ebuild b/dev-qt/assistant/assistant-5.15.5.ebuild
new file mode 100644
index 000000000000..52bf83ac3a7d
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.15.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*[png]
+ =dev-qt/qthelp-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtprintsupport-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}
+ !dev-qt/${PN}:5
+ !<dev-qt/qtchooser-66-r2
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
+ -i src/assistant/assistant/assistant.pro || die
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path assistant
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}