summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-26 11:18:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-26 16:32:27 +0200
commitaeb61e1abdbb629279cb188180567a3fb957d9e5 (patch)
tree1425b69473c31cd902abba3a496763dd2a325396 /dev-qt/linguist
parentqt5-build.eclass: Drop pre-Qt 5.14 quirks (diff)
downloadgentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.tar.gz
gentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.tar.bz2
gentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.zip
dev-qt: Add Qt 5.15.0 release
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/linguist')
-rw-r--r--dev-qt/linguist/Manifest1
-rw-r--r--dev-qt/linguist/linguist-5.15.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-qt/linguist/Manifest b/dev-qt/linguist/Manifest
index 57f7915196f5..daea0cdeb149 100644
--- a/dev-qt/linguist/Manifest
+++ b/dev-qt/linguist/Manifest
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.1.tar.xz 8810972 BLAKE2B 324246728e814eeb5d297fe72cfdc8af584c555f4676f8f6325c9f2353140dc04c98b3f1e1d39ffacecd43527e13df1ce1b1608377794eb8247d3f2549d6697b SHA512 59874ed00f7f9749f0dda49d6e1ad064d1594c6b0bde577961c5d45628763d2a2031aa7ebed952f1cebc8a241eb6a0e4a4f8e36c0a93ffe738a0ff360b8d3f30
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
+DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
diff --git a/dev-qt/linguist/linguist-5.15.0.ebuild b/dev-qt/linguist/linguist-5.15.0.ebuild
new file mode 100644
index 000000000000..4aa1294c58f7
--- /dev/null
+++ b/dev-qt/linguist/linguist-5.15.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Graphical tool for translating Qt applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/designer-${PV}
+ ~dev-qt/qtcore-${PV}:5=
+ ~dev-qt/qtgui-${PV}:5=
+ ~dev-qt/qtprintsupport-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ ~dev-qt/qtxml-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/linguist/linguist
+)
+
+src_install() {
+ qt5-build_src_install
+
+ local size
+ for size in 16 32 48 64 128; do
+ newicon -s ${size} src/linguist/linguist/images/icons/linguist-${size}-32.png linguist.png
+ done
+ make_desktop_entry "${QT5_BINDIR}"/linguist 'Qt 5 Linguist' linguist 'Qt;Development;Translation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}