summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-01 20:57:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-01 22:01:18 +0100
commitb2948231f865474cc537e22fa5c24e4a89e7a069 (patch)
tree2680b7b6ca4ac985ade9b99901b8d63670f8f16c /dev-qt/pixeltool/pixeltool-5.15.12.ebuild
parentdev-qt/linguist-tools: add 5.15.12 (diff)
downloadgentoo-b2948231f865474cc537e22fa5c24e4a89e7a069.tar.gz
gentoo-b2948231f865474cc537e22fa5c24e4a89e7a069.tar.bz2
gentoo-b2948231f865474cc537e22fa5c24e4a89e7a069.zip
dev-qt/pixeltool: add 5.15.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/pixeltool/pixeltool-5.15.12.ebuild')
-rw-r--r--dev-qt/pixeltool/pixeltool-5.15.12.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/pixeltool/pixeltool-5.15.12.ebuild b/dev-qt/pixeltool/pixeltool-5.15.12.ebuild
new file mode 100644
index 000000000000..cdc560882599
--- /dev/null
+++ b/dev-qt/pixeltool/pixeltool-5.15.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt screen magnifier"
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[png]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}
+ !dev-qt/${PN}:5
+ !<dev-qt/qtchooser-66-r2
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/pixeltool
+)
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path pixeltool
+}