summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-13 23:12:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-13 23:44:20 +0200
commitf8a9586bf99471bc6033768f56c9117fba365bcc (patch)
tree3669b34eb35dade2f12da4ee870c3233b40e3dd1 /dev-qt/qtbluetooth/qtbluetooth-5.15.9.ebuild
parentdev-qt/qt3d: 5.15.9 version bump (diff)
downloadgentoo-f8a9586bf99471bc6033768f56c9117fba365bcc.tar.gz
gentoo-f8a9586bf99471bc6033768f56c9117fba365bcc.tar.bz2
gentoo-f8a9586bf99471bc6033768f56c9117fba365bcc.zip
dev-qt/qtbluetooth: 5.15.9 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtbluetooth/qtbluetooth-5.15.9.ebuild')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.15.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.15.9.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.15.9.ebuild
new file mode 100644
index 000000000000..e7c437157c60
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.15.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+QT5_MODULE="qtconnectivity"
+inherit qt5-build
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+IUSE="qml"
+
+DEPEND="
+ =dev-qt/qtconcurrent-${QT5_PV}*
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdbus-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ >=net-wireless/bluez-5:=
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build_src_prepare
+}