summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-17 21:58:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-21 12:03:15 +0100
commit4e143c40fce79488737bc1b4dec567e0882e1b6c (patch)
tree97d747729a91465bd736e5997e3ede0c6be01db2 /dev-qt/qtchooser
parentdev-python/braintree: Add support for Python 3.10 (diff)
downloadgentoo-4e143c40fce79488737bc1b4dec567e0882e1b6c.tar.gz
gentoo-4e143c40fce79488737bc1b4dec567e0882e1b6c.tar.bz2
gentoo-4e143c40fce79488737bc1b4dec567e0882e1b6c.zip
dev-qt/qtchooser: Drop tools colliding with Qt 5.15.3 links
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtchooser')
-rw-r--r--dev-qt/qtchooser/files/qtchooser-66-qt-5.15.3-compat.patch33
-rw-r--r--dev-qt/qtchooser/qtchooser-66-r2.ebuild73
2 files changed, 106 insertions, 0 deletions
diff --git a/dev-qt/qtchooser/files/qtchooser-66-qt-5.15.3-compat.patch b/dev-qt/qtchooser/files/qtchooser-66-qt-5.15.3-compat.patch
new file mode 100644
index 000000000000..0a8569ff90b8
--- /dev/null
+++ b/dev-qt/qtchooser/files/qtchooser-66-qt-5.15.3-compat.patch
@@ -0,0 +1,33 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,18 +1,13 @@
+ MKDIR = mkdir -p
+ prefix = /usr
+ bindir = $(prefix)/bin
+-TOOLS = assistant \
+- designer \
++TOOLS = designer \
+ lconvert \
+- linguist \
+ lrelease \
+ lupdate \
+ moc \
+- pixeltool \
+ qcollectiongenerator \
+- qdbus \
+ qdbuscpp2xml \
+- qdbusviewer \
+ qdbusxml2cpp \
+ qdoc \
+ qdoc3 \
+@@ -44,9 +39,7 @@
+ rcc \
+ repc \
+ uic \
+- uic3 \
+- xmlpatterns \
+- xmlpatternsvalidator \
++ uic3
+
+ # keep the above line empty
+
diff --git a/dev-qt/qtchooser/qtchooser-66-r2.ebuild b/dev-qt/qtchooser/qtchooser-66-r2.ebuild
new file mode 100644
index 000000000000..9d7f138515f6
--- /dev/null
+++ b/dev-qt/qtchooser/qtchooser-66-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils toolchain-funcs
+
+DESCRIPTION="Tool to quickly switch between multiple Qt installations"
+HOMEPAGE="https://code.qt.io/cgit/qtsdk/qtchooser.git/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://code.qt.io/qtsdk/qtchooser.git"
+ inherit git-r3
+else
+ SRC_URI="https://download.qt.io/official_releases/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="|| ( LGPL-2.1 GPL-3 )"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ dev-qt/qtcore:5
+ dev-qt/qttest:5
+ )"
+RDEPEND="!<dev-qt/qtcore-5.15.3:5"
+
+PATCHES=( "${FILESDIR}/${PN}-66-qt-5.15.3-compat.patch" )
+
+qtchooser_make() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ LFLAGS="${LDFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ "$@"
+}
+
+src_compile() {
+ qtchooser_make
+}
+
+src_test() {
+ pushd tests/auto >/dev/null || die
+ eqmake5
+ popd >/dev/null || die
+
+ qtchooser_make check
+}
+
+src_install() {
+ qtchooser_make INSTALL_ROOT="${D}" install
+
+ # install configuration file
+ cat > "${T}/qt5-${CHOST}.conf" <<-_EOF_ || die
+ $(qt5_get_bindir)
+ $(qt5_get_libdir)
+ _EOF_
+
+ (
+ insinto /etc/xdg/qtchooser
+ doins "${T}/qt5-${CHOST}.conf"
+ )
+
+ # convenience symlinks
+ dosym qt5-"${CHOST}".conf /etc/xdg/qtchooser/5.conf
+ dosym qt5-"${CHOST}".conf /etc/xdg/qtchooser/qt5.conf
+ dosym qt5.conf /etc/xdg/qtchooser/default.conf
+
+ # TODO: bash and zsh completion
+ # newbashcomp scripts/${PN}.bash ${PN}
+}