summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-13 16:26:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-18 18:15:28 +0200
commit1c0947091db651f4e7d136e22d4887b47d9245cd (patch)
treedd264a79b23c6103b138807ca5b05d76fcd07959 /dev-qt/qtdeclarative
parentmedia-sound/alsa-utils: x86 stable (bug #749159) (diff)
downloadgentoo-1c0947091db651f4e7d136e22d4887b47d9245cd.tar.gz
gentoo-1c0947091db651f4e7d136e22d4887b47d9245cd.tar.bz2
gentoo-1c0947091db651f4e7d136e22d4887b47d9245cd.zip
dev-qt: Drop Qt 5.14.2
Bug: https://bugs.gentoo.org/734600 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtdeclarative')
-rw-r--r--dev-qt/qtdeclarative/Manifest1
-rw-r--r--dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-QQuickMouseArea-stuck-in-pressed-state.patch55
-rw-r--r--dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-fix-subpixel-positioned-text.patch64
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.14.2-r4.ebuild59
4 files changed, 0 insertions, 179 deletions
diff --git a/dev-qt/qtdeclarative/Manifest b/dev-qt/qtdeclarative/Manifest
index fc9e295e584b..a84d768da2c5 100644
--- a/dev-qt/qtdeclarative/Manifest
+++ b/dev-qt/qtdeclarative/Manifest
@@ -1,2 +1 @@
-DIST qtdeclarative-everywhere-src-5.14.2.tar.xz 21305980 BLAKE2B 0ccbae8ddc46f4891af6732a4b3cf874c523c7ded5a06f78c7c5cd290fef8e32ad6efe5dcffe947024144128ab2f1108594e4a30da9ca79e1ce3008c73ca2a25 SHA512 48d3a547237514a8bdc2a4c0b3f97732abceacece0e0899d2f33787293eb99f54c28efce35a34b8c46dcd4d78ebbc88bfc820bc68496076eacace40aaceee004
DIST qtdeclarative-everywhere-src-5.15.1.tar.xz 21558724 BLAKE2B 15da5471799e461e5f5983fb0d947cad9d635a1bb0760da0b709f273ba9a9846df442f424d2009e857d831695d14a92c9be941270a07dc0f33cc46382ba44e6f SHA512 193ec706b764330a2ae00614b13482b7586642f9cfd32458e8c975daa07ba25f0f9887de0918c4034f52f613b860677c09c46a3b7d07d4229446cfc0805bcccd
diff --git a/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-QQuickMouseArea-stuck-in-pressed-state.patch b/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-QQuickMouseArea-stuck-in-pressed-state.patch
deleted file mode 100644
index 1dd0ff1155de..000000000000
--- a/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-QQuickMouseArea-stuck-in-pressed-state.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 8ace780b5aa298e3c01903bfd57f766a42209191 Mon Sep 17 00:00:00 2001
-From: Frederik Gladhorn <frederik.gladhorn@remarkable.com>
-Date: Sat, 28 Mar 2020 15:14:41 +0100
-Subject: [PATCH] Fix QQuickMouseArea getting stuck in pressed state when
- hiding in press
-MIME-Version: 1.0
-Content-Type: text/plain; charset=utf8
-Content-Transfer-Encoding: 8bit
-
-In 78c1fcbc49f56463064eef738a475d9018357b24 we stopped giving the
-exclusive grab to hidden or disabled items with is good. But the change
-did not take into consideration how mouse area handles its internal
-state.
-
-As a simple example: A mouse area that would set itself hiddin in the
-press handler, would continue to have d->pressed == true, which means it
-would not react to any future press events.
-
-The fix is to let mouse area check in its change handler whether it has
-become invisible.
-The test also checks that enabled behaves the same way. There is no
-action needed, since mouse area does completely custom handling of
-enabled (maybe something to fix in Qt 6), disabling a mouse area doesn't
-disable its children for example, it doesn't invoke
-QQuickItem::setEnabled at all. Due to this circumventing the common
-behavior, by chance disabling a mouse area in the on pressed handler
-works.
-
-Fixes: QTBUG-74987
-Change-Id: Idb8499b3e5bcb744fbba203fdea5c46695bd5077
-Reviewed-by: Jan Arve Sæther <jan-arve.saether@qt.io>
----
- src/quick/items/qquickmousearea.cpp | 6 ++++
- 3 files changed, 80 insertions(+)
- create mode 100644 tests/auto/quick/qquickmousearea/data/settingHiddenInPressUngrabs.qml
-
-diff --git a/src/quick/items/qquickmousearea.cpp b/src/quick/items/qquickmousearea.cpp
-index 368379f5c40..dc60712a9cd 100644
---- a/src/quick/items/qquickmousearea.cpp
-+++ b/src/quick/items/qquickmousearea.cpp
-@@ -1083,6 +1083,12 @@ void QQuickMouseArea::itemChange(ItemChange change, const ItemChangeData &value)
- }
- setHovered(!d->hovered);
- }
-+ if (d->pressed && (!isVisible())) {
-+ // This happens when the mouse area sets itself disabled or hidden
-+ // inside the press handler. In that case we should not keep the internal
-+ // state as pressed, since we never became the mouse grabber.
-+ ungrabMouse();
-+ }
- break;
- default:
- break;
---
-2.16.3
diff --git a/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-fix-subpixel-positioned-text.patch b/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-fix-subpixel-positioned-text.patch
deleted file mode 100644
index 23eaa7d5100d..000000000000
--- a/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-fix-subpixel-positioned-text.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From e807f9d1d80559b8ff91f1c3cfdd755b3da56a6d Mon Sep 17 00:00:00 2001
-From: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
-Date: Tue, 5 May 2020 11:36:24 +0200
-Subject: [PATCH] Fix subpixel positioned text with Text.NativeRendering
-
-We would be generating subpixel positioned glyphs based on the
-relative positions of the glyphs, ignoring the fractional part
-contributed by the origin of the text. So if the text origin was
-inside a pixel, the subpixel antialiasing would be wrong and we
-would see kerning errors.
-
-This was especially visible when using AlignHCenter on text
-with hinting disabled and resizing the item it was aligning to.
-
-Pick-to: 5.15
-Task-number: QTBUG-49646
-Change-Id: I0e709ba2b5d2440e34c94c6f819befe0a65a113a
-Reviewed-by: Lars Knoll <lars.knoll@qt.io>
-Reviewed-by: Konstantin Ritt <ritt.ks@gmail.com>
----
- src/quick/scenegraph/qsgdefaultglyphnode_p.cpp | 9 ++++-----
- 1 file changed, 4 insertions(+), 5 deletions(-)
-
-diff --git a/src/quick/scenegraph/qsgdefaultglyphnode_p.cpp b/src/quick/scenegraph/qsgdefaultglyphnode_p.cpp
-index cfa645bfd03..f73b64f537f 100644
---- a/src/quick/scenegraph/qsgdefaultglyphnode_p.cpp
-+++ b/src/quick/scenegraph/qsgdefaultglyphnode_p.cpp
-@@ -789,11 +789,12 @@ void QSGTextMaskMaterial::populate(const QPointF &p,
- const QMargins &margins)
- {
- Q_ASSERT(m_font.isValid());
-+ QPointF position(p.x(), p.y() - m_font.ascent());
- QVector<QFixedPoint> fixedPointPositions;
- const int glyphPositionsSize = glyphPositions.size();
- fixedPointPositions.reserve(glyphPositionsSize);
- for (int i=0; i < glyphPositionsSize; ++i)
-- fixedPointPositions.append(QFixedPoint::fromPointF(glyphPositions.at(i)));
-+ fixedPointPositions.append(QFixedPoint::fromPointF(position + glyphPositions.at(i)));
-
- QTextureGlyphCache *cache = glyphCache();
-
-@@ -815,18 +816,16 @@ void QSGTextMaskMaterial::populate(const QPointF &p,
- Q_ASSERT(geometry->sizeOfVertex() == sizeof(QVector4D));
- ushort *ip = geometry->indexDataAsUShort();
-
-- QPointF position(p.x(), p.y() - m_font.ascent());
- bool supportsSubPixelPositions = fontD->fontEngine->supportsSubPixelPositions();
- for (int i=0; i<glyphIndexes.size(); ++i) {
-+ QPointF glyphPosition = glyphPositions.at(i) + position;
- QFixed subPixelPosition;
- if (supportsSubPixelPositions)
-- subPixelPosition = fontD->fontEngine->subPixelPositionForX(QFixed::fromReal(glyphPositions.at(i).x()));
-+ subPixelPosition = fontD->fontEngine->subPixelPositionForX(QFixed::fromReal(glyphPosition.x()));
-
- QTextureGlyphCache::GlyphAndSubPixelPosition glyph(glyphIndexes.at(i), subPixelPosition);
- const QTextureGlyphCache::Coord &c = cache->coords.value(glyph);
-
-- QPointF glyphPosition = glyphPositions.at(i) + position;
--
- // On a retina screen the glyph positions are not pre-scaled (as opposed to
- // eg. the raster paint engine). To ensure that we get the same behavior as
- // the raster engine (and CoreText itself) when it comes to rounding of the
---
-2.16.3
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r4.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r4.ebuild
deleted file mode 100644
index ee5e2c5a785e..000000000000
--- a/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2009-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1 qt5-build
-
-DESCRIPTION="The QML and Quick modules for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
-fi
-
-IUSE="gles2-only +jit localstorage vulkan +widgets"
-
-BDEPEND="${PYTHON_DEPS}"
-# qtgui[gles2-only=] is needed because of bug 504322
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}:5=[gles2-only=,vulkan=]
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qttest-${PV}
- localstorage? ( ~dev-qt/qtsql-${PV} )
- widgets? ( ~dev-qt/qtwidgets-${PV}[gles2-only=] )
-"
-RDEPEND="${DEPEND}
- !<dev-qt/qtquickcontrols-5.7:5
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-QQuickItemView-fix-maxXY-extent.patch" # QTBUG-83890
- "${FILESDIR}/${P}-fix-subpixel-positioned-text.patch" # QTBUG-49646
- "${FILESDIR}/${P}-QQuickMouseArea-stuck-in-pressed-state.patch" # QTBUG-74987
-)
-
-src_prepare() {
- use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
-
- qt_use_disable_mod localstorage sql \
- src/imports/imports.pro
-
- qt_use_disable_mod widgets widgets \
- src/src.pro \
- src/qmltest/qmltest.pro \
- tests/auto/auto.pro \
- tools/tools.pro \
- tools/qmlscene/qmlscene.pro \
- tools/qml/qml.pro
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myqmakeargs=(
- --
- -qml-debug
- )
- qt5-build_src_configure
-}