summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-05 23:49:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-06 20:34:45 +0100
commit76bf1c12fa3aedcd336e9eff02e114f4f5abdd8b (patch)
tree62419050fdb23032209951954da924f1c7445fba /dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild
parentdev-qt/qtpositioning: Enable USE qml by default (diff)
downloadgentoo-76bf1c12fa3aedcd336e9eff02e114f4f5abdd8b.tar.gz
gentoo-76bf1c12fa3aedcd336e9eff02e114f4f5abdd8b.tar.bz2
gentoo-76bf1c12fa3aedcd336e9eff02e114f4f5abdd8b.zip
dev-qt/qtlocation: Add USE-DEPEND on dev-qt/qtpositioning[qml]
For usage of QtPositioningQuick. While location-labs-plugin is optional, declarativemaps is built and depends on QtPositioningQuick unconditionally. It is probably for this reason that ${PN} already unconditionally depends on dev-qt/qtdeclarative, so making the plugin optional would save us nothing. Bug: https://bugs.gentoo.org/669608 Reported-by: Toralf Förster <toralf@gentoo.org> Thanks-to: Jimi Huotari <chiitoo@gentoo.org> Thanks-to: Iade Gesso <iade.gesso@gmail.com> Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild')
-rw-r--r--dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild b/dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild
new file mode 100644
index 000000000000..78057b719907
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.11.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="The Location module for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}