summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-24 08:15:14 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-24 14:37:30 -0400
commit4e130498a51abffc7d0e4ac35c4b6db59e6e3c03 (patch)
treea19d05efefb279637bbc19a7c38de185d7dce1fd /dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild
parentdev-qt/qtimageformats: drop 6.7.0_rc (diff)
downloadgentoo-4e130498a51abffc7d0e4ac35c4b6db59e6e3c03.tar.gz
gentoo-4e130498a51abffc7d0e4ac35c4b6db59e6e3c03.tar.bz2
gentoo-4e130498a51abffc7d0e4ac35c4b6db59e6e3c03.zip
dev-qt/qtlocation: drop 6.7.0_rc
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild')
-rw-r--r--dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild b/dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild
deleted file mode 100644
index 112102c1365c..000000000000
--- a/dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network]
- ~dev-qt/qtdeclarative-${PV}:6
- ~dev-qt/qtpositioning-${PV}:6[qml]
-"
-DEPEND="${RDEPEND}"
-
-CMAKE_SKIP_TESTS=(
- # ignores QML_IMPORT_PATH (unlike other tests) and looks in
- # the missing builddir/qml, skip rather than work around
- tst_declarative_ui
-)
-
-src_install() {
- qt6-build_src_install
-
- if use test; then
- local delete=( # sigh
- "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
- "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
- "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
- "${D}${QT6_QMLDIR}"/QtLocation/Test
- )
- # using -f given not tracking which tests may be skipped or not
- rm -rf -- "${delete[@]}" || die
- fi
-}