summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-20 21:35:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-20 21:42:18 +0200
commit2e4ecdc14b2a17aa8e34b7a8d9d0b9c2eaa32355 (patch)
tree6156f5d8389f1e437b20893452f7ddada861db40 /dev-qt/qtlocation
parentdev-qt/qtimageformats: 5.15.4 version bump (diff)
downloadgentoo-2e4ecdc14b2a17aa8e34b7a8d9d0b9c2eaa32355.tar.gz
gentoo-2e4ecdc14b2a17aa8e34b7a8d9d0b9c2eaa32355.tar.bz2
gentoo-2e4ecdc14b2a17aa8e34b7a8d9d0b9c2eaa32355.zip
dev-qt/qtlocation: 5.15.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest2
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.4.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 9173591dfd8c..ace8e30d251f 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,2 +1,4 @@
DIST qtlocation-5.15.3-gentoo-kde-2.tar.xz 1000 BLAKE2B bf03283153bed5f2e67cfcc42784fb6cec7574492cbc63979316602e9f2684fdd10f140b743f82076ec39e0831faa8a5a2074e9cfdf7c4743eff354e076b635f SHA512 f44f5aa2f6aac3a62fbc3cc6eaa88949d54f4238d1cbc12d770ba3b48f97712678c491083029ba871fb9eb31f5172296e8951e83a3f874ac2a8a1a78478559e4
+DIST qtlocation-5.15.4-gentoo-kde-1.tar.xz 1000 BLAKE2B d50546826373a9123f91d2e21f670c030a4a9530494c4ab173a4045f79ea7c6907e39c0acb57e7e3e872146ad72785c4b72b7257672e432ff5870730f66a54cc SHA512 5d2217a3d40b873cd6b0b7c7815a9a52aa19824b7c2aed1d1ea3dac2fafa8b2af9a62ff3dacbdcb588072f2edb1cb226bc808d094ca4c6240a58835d4e93854c
DIST qtlocation-everywhere-opensource-src-5.15.3.tar.xz 6556680 BLAKE2B aa187e23ed544e380516d93f3cb83fcff73ee501e7b790eb55b9ca9ddcdbf96d31b8b645b70e003423bf6e8945e2fb06be0ba62785a1ba5680acca2129003d83 SHA512 755434db4cdea1c98159a2891c3efcda03fd03b144c37e7a71f57cb5d5dbc5ea1b35d1dcafa7301fc904ede910b4a9f7cfc834b7722cc06fcc360ad3be7b2886
+DIST qtlocation-everywhere-opensource-src-5.15.4.tar.xz 6559260 BLAKE2B ea43ae7e788f7d117fea9db50660cc2f4e7b6f8cf4ae390b41ed3adfa794d66596d8d7ac184d1edc432d2aa6057727321459a29ddbe399201ad428d290982297 SHA512 6208052d6ac173d19dc77496d8108558e7f31696dc5792fcbbeef2029539db76a60c5a51a7d198f54ea6c0ec23977a57cd8c8f8fa80fe5eac9528d2510c3dbb3
diff --git a/dev-qt/qtlocation/qtlocation-5.15.4.ebuild b/dev-qt/qtlocation/qtlocation-5.15.4.ebuild
new file mode 100644
index 000000000000..ba9e9fc91df0
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}