summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-19 23:12:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-26 12:52:19 +0200
commit6519752b4d6e8609db3a09a2a3da94d329d443e2 (patch)
treeb7e6971385f93526a1888c16ab2f3fd20fffc766 /dev-qt/qtsql/qtsql-5.12.5-r2.ebuild
parentdev-libs/expat: Remove vulnerable (diff)
downloadgentoo-6519752b4d6e8609db3a09a2a3da94d329d443e2.tar.gz
gentoo-6519752b4d6e8609db3a09a2a3da94d329d443e2.tar.bz2
gentoo-6519752b4d6e8609db3a09a2a3da94d329d443e2.zip
dev-qt/qtsql: Fix build against PostgreSQL 12.0
Backport from qtsql 5.14 branch. Tested-by: Nils Freydank <holgersson@posteo.de> Bug: https://bugs.gentoo.org/696870 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtsql/qtsql-5.12.5-r2.ebuild')
-rw-r--r--dev-qt/qtsql/qtsql-5.12.5-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-qt/qtsql/qtsql-5.12.5-r2.ebuild b/dev-qt/qtsql/qtsql-5.12.5-r2.ebuild
new file mode 100644
index 000000000000..48eb0930db10
--- /dev/null
+++ b/dev-qt/qtsql/qtsql-5.12.5-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="SQL abstraction library for the Qt5 framework"
+SLOT=5/$(ver_cut 1-3) # bug 639140
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="freetds mysql oci8 odbc postgres +sqlite"
+
+REQUIRED_USE="
+ || ( freetds mysql oci8 odbc postgres sqlite )
+"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ freetds? ( dev-db/freetds )
+ mysql? ( dev-db/mysql-connector-c:= )
+ oci8? ( dev-db/oracle-instantclient:=[sdk] )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/sql
+ src/plugins/sqldrivers
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :sql
+)
+
+PATCHES+=(
+ # Backport from 5.14 branch, bug #696870
+ "${FILESDIR}/${P}-postgresql-12.patch"
+ # Backport from dev branch
+ "${FILESDIR}/${PN}-5.12.4-mysql_free_results_when_qsqlquery_finished_is_called.patch"
+)
+
+src_configure() {
+ local myconf=(
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use mysql sql-mysql plugin)
+ $(qt_use oci8 sql-oci plugin)
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use postgres sql-psql plugin)
+ $(qt_use sqlite sql-sqlite plugin)
+ $(usex sqlite -system-sqlite '')
+ )
+
+ use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")
+
+ qt5-build_src_configure
+}