summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-28 22:39:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-28 23:12:49 +0100
commit7c317846b7095f0a782516c2a44deda4adc63091 (patch)
tree7622ebfeef8333ebebe5c9fa2c071fd0091d9c6f /dev-qt/qtsql/qtsql-5.14.1.ebuild
parentdev-python/pyqtgraph: adding python 3.7 (diff)
downloadgentoo-7c317846b7095f0a782516c2a44deda4adc63091.tar.gz
gentoo-7c317846b7095f0a782516c2a44deda4adc63091.tar.bz2
gentoo-7c317846b7095f0a782516c2a44deda4adc63091.zip
dev-qt: 5.14.1 version bump
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtsql/qtsql-5.14.1.ebuild')
-rw-r--r--dev-qt/qtsql/qtsql-5.14.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-qt/qtsql/qtsql-5.14.1.ebuild b/dev-qt/qtsql/qtsql-5.14.1.ebuild
new file mode 100644
index 000000000000..473bf4e8bccc
--- /dev/null
+++ b/dev-qt/qtsql/qtsql-5.14.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="SQL abstraction library for the Qt5 framework"
+SLOT=5/$(ver_cut 1-3) # bug 639140
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="freetds mysql oci8 odbc postgres +sqlite"
+
+REQUIRED_USE="
+ || ( freetds mysql oci8 odbc postgres sqlite )
+"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ freetds? ( dev-db/freetds )
+ mysql? ( dev-db/mysql-connector-c:= )
+ oci8? ( dev-db/oracle-instantclient:=[sdk] )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/sql
+ src/plugins/sqldrivers
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :sql
+)
+
+src_configure() {
+ local myconf=(
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use mysql sql-mysql plugin)
+ $(qt_use oci8 sql-oci plugin)
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use postgres sql-psql plugin)
+ $(qt_use sqlite sql-sqlite plugin)
+ $(usex sqlite -system-sqlite '')
+ )
+
+ use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")
+
+ qt5-build_src_configure
+}