summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-16 06:41:32 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-16 06:42:18 -0400
commit439235378939f21bc640f88dadef4f2da170898c (patch)
tree68ccc203a1dd37498b36f95d2184146a8b61f9fb /dev-qt/qtwayland/qtwayland-6.9999.ebuild
parentmedia-plugins/calf: eapi8 + updated desktop patch in live ebuild (diff)
downloadgentoo-439235378939f21bc640f88dadef4f2da170898c.tar.gz
gentoo-439235378939f21bc640f88dadef4f2da170898c.tar.bz2
gentoo-439235378939f21bc640f88dadef4f2da170898c.zip
dev-qt/qtwayland: unset session variables for tests (qt6)
Closes: https://bugs.gentoo.org/927030 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland/qtwayland-6.9999.ebuild')
-rw-r--r--dev-qt/qtwayland/qtwayland-6.9999.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/qtwayland-6.9999.ebuild b/dev-qt/qtwayland/qtwayland-6.9999.ebuild
index 90842e7be4d0..dc3ce8575fd3 100644
--- a/dev-qt/qtwayland/qtwayland-6.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.9999.ebuild
@@ -45,3 +45,11 @@ src_configure() {
qt6-build_src_configure
}
+
+src_test() {
+ # users' session setting may break tst_clientextension (bug #927030)
+ unset DESKTOP_SESSION XDG_CURRENT_DESKTOP
+ unset GNOME_DESKTOP_SESSION_ID KDE_FULL_SESSION
+
+ qt6-build_src_test
+}