summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-29 14:10:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-29 14:42:39 +0200
commit1e66491630ec381eded82050e39e25fb502e6dc4 (patch)
treee319be7fcc0a9daaae29b44d0e58ee2bce7afaa2 /dev-qt/qtwayland
parentdev-qt/qtprintsupport: Revert CUPS support for accessible IPP printers (diff)
downloadgentoo-1e66491630ec381eded82050e39e25fb502e6dc4.tar.gz
gentoo-1e66491630ec381eded82050e39e25fb502e6dc4.tar.bz2
gentoo-1e66491630ec381eded82050e39e25fb502e6dc4.zip
dev-qt/qtwayland: Bump to QT5_KDEPATCHSET_REV=2
Ville Voutilainen (1): Build fixes for GCC 11 Weng Xuetian (1): Only close popup in the the hierchary Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.5-r1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index e6a3a8508197..3c4c3c65c7db 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
DIST qtwayland-5.15.5-gentoo-kde-1.tar.xz 32076 BLAKE2B e42d847deaef08271eb2f3211db7496bb1d3e1da976cf242f2129775c0401eb834fd7c94b35ac58d601eb28e770c3b6bedaf4135e5ad97f43e0adee5054214aa SHA512 277c3612de892f21058bac3ef9c2b3584aa43850e1f6dab0c43989a952e30656c6069d1f7d07b0f1df7d1ec2ab1893a0ba1c4c6fecc6f56c101333832bdd483c
+DIST qtwayland-5.15.5-gentoo-kde-2.tar.xz 35492 BLAKE2B 91334609155e4bd227d76e5972422b400ab4b6196389a1b6b4c271994287851bc3b624ae761ece1418037735784edf7740ed5337ef6972bf708c598c202b7e86 SHA512 2663b59c7647e8a7d5f64905be114fc1b248cd8e10c2eba6bddc25b74fbbc5216e8264f41f50b6368819664921e27dfe96d4c1556c0e56f8c3c2c0ed75a72080
DIST qtwayland-everywhere-opensource-src-5.15.5.tar.xz 567384 BLAKE2B 01ce4d546bda7bf332f8cc4f86a5e8bfb1be0ef60336ee3cae58266a25d51cf00fef3e6c4204f0179abc2ef748f88bd3a20f89f36da74d5d15c70ae7b4975186 SHA512 828dceb7bc54ce610a73f110f0aca332a90cf95df4a3bc971bd21c4e878366cb8d2248e609b73ce4d381579a143843c87a62f23dcc95767e522874e53a1b0327
diff --git a/dev-qt/qtwayland/qtwayland-5.15.5-r1.ebuild b/dev-qt/qtwayland/qtwayland-5.15.5-r1.ebuild
new file mode 100644
index 000000000000..82916bcd104b
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.5-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=2
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+SLOT=5/${QT5_PV} # bug 815646
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.15.2-QTBUG-90037-QTBUG-91264.patch" # upstream pending
+ "${FILESDIR}/${PN}-5.15.3-clang.patch"
+)
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}
+
+src_install() {
+ qt5-build_src_install
+ rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
+}