summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-11 12:08:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 09:30:35 +0200
commit78d7f867dc4fa787c5b5f44de86cd2cc043d3d45 (patch)
tree02f4ea207e9cad8f4321d7633a9f18bf7682fc5d /dev-qt/qtwayland
parentdev-qt/qt-docs: 5.12.5_p201908230013 version bump (diff)
downloadgentoo-78d7f867dc4fa787c5b5f44de86cd2cc043d3d45.tar.gz
gentoo-78d7f867dc4fa787c5b5f44de86cd2cc043d3d45.tar.bz2
gentoo-78d7f867dc4fa787c5b5f44de86cd2cc043d3d45.zip
dev-qt: Add Qt 5.12.5
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.12.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 0b7855071651..198b0f30bad1 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
DIST qtwayland-everywhere-src-5.12.3.tar.xz 432304 BLAKE2B eb2ba520c651467c8ed5f0d870a69c9b07047cb4c05a0c889b36abeab30149861b83ca693efb0bb93dce4f5da5913afc3c8b61933ef0e8307d22b64fce530d87 SHA512 e66f9f41c15cf84165e559a1ff09e20ec21bb3f909b57fab08b0e3f8f9eeacf75d49541b499b1a6514a34d1ba5dd426ec1ce77719910588afa12cb3a7980dc90
DIST qtwayland-everywhere-src-5.12.4.tar.xz 434076 BLAKE2B f034080ec3ad8281c10edcdaa56bf2bcac2ea0002bb2b4780fce40cc28bcf30db713c736916f3382aa7ad0418f5ac424064d675c7001968378487d9cb40c619f SHA512 f3fd6644d7fa21ef042ecda807f6ede7853944de8908f8d390f0ebec258406ff4a4f3bfbb382b57a7a4684e19906b79b43c920f55c5fda75bacfc9a96fafa301
+DIST qtwayland-everywhere-src-5.12.5.tar.xz 448064 BLAKE2B e9ec631d1ec0f19cc5ef9f3c9e9e12d327da8ad896e40bb172b98191947ff20ba33b0fc747a9009d4d9147dd1cdea2d5376a12f25362bfa499eca6d0c838f2d2 SHA512 19e19b3d6226839856f8e8792665eda1f09f0bbf95a38077bdf2831205ee09254c8df6a521ba3f5a228bcd98c4d1929a2bd9e9aa2f6f14c218d4d7458d1a866c
diff --git a/dev-qt/qtwayland/qtwayland-5.12.5.ebuild b/dev-qt/qtwayland/qtwayland-5.12.5.ebuild
new file mode 100644
index 000000000000..ac4fdc112362
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.12.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ src/plugins/shellintegration/wl-shell/wl-shell.pro \
+ src/plugins/shellintegration/xdg-shell/xdg-shell.pro \
+ src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro \
+ src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}