summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-12 22:09:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-12 22:24:23 +0100
commit8f2e8db71d9a21b58d2cade0045b3ed41bc534a2 (patch)
tree3298603d4b1e1826e4c624a95db331ae71ac4c3b /dev-qt/qtwayland
parentapp-antivirus/clamav: new upstream security release v0.104.2. (diff)
downloadgentoo-8f2e8db71d9a21b58d2cade0045b3ed41bc534a2.tar.gz
gentoo-8f2e8db71d9a21b58d2cade0045b3ed41bc534a2.tar.bz2
gentoo-8f2e8db71d9a21b58d2cade0045b3ed41bc534a2.zip
dev-qt/qtwayland: 5.15.2-r17 version bump at 867540b9
Changes since 5.15.2-r16: Arjen Hiemstra (1): Client: Delay deletion of QDrag object until after we're done with it David Edmundson (1): Client: Implement DataDeviceV3 Weng Xuetian (1): Set preedit cursor when cursor equals to 0 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2-r17.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 18076e21b623..abf1cb63eafc 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1 +1,2 @@
+DIST qtwayland-5.15.2-867540b9.tar.gz 830061 BLAKE2B b831288d6a3e671631b4df00eb1edb72e35128f3ed5a73983b3e15193f554fddcd0337deb832d44b795d2e37f0601fe35b8b0fcb5986bcc44154d172f3a54193 SHA512 b834802811d9f65559ef5e7468189b53c666e390aa09edeb490e5fee2dece13082b11da0f8b5924b89f7dc8e1eba375a485940f4dfbf0445f3d1e96033e33f24
DIST qtwayland-5.15.2-eb422ab5.tar.gz 829140 BLAKE2B e913e481741b23873a88db32896c7f3445a2ddee2dc9cfdf8e132fdd79021de369506e32ce9ed50977fb1c42d624169b7d67c9247f7609276e699e5ab3a9462e SHA512 b5094b00feab5909b4de6382a3633fc321d5f5fbc34e4cbde1f364123b24990df95cef5c34a90f73dca67b0578e0da71b894f771ebbd8d152dcdc71b114d9773
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2-r17.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2-r17.ebuild
new file mode 100644
index 000000000000..658532095a0c
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.2-r17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_COMMIT=867540b9d913760a847ff67c8694d817c821f2c2
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+SLOT=5/${QT5_PV} # bug 815646
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}