summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-10-14 18:30:50 +0300
committerSam James <sam@gentoo.org>2022-11-02 05:09:45 +0000
commitc2b15ca2f28c0decd82dff7167b73a455ac1c7b1 (patch)
tree12faa77e4e5a7d7972c14606fab54d457d2ea6a8 /dev-qt/qtwayland
parentqt6-build.eclass: add qt6-build_src_install (diff)
downloadgentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.tar.gz
gentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.tar.bz2
gentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.zip
dev-qt/*: add version 6.4.0
Bug: https://bugs.gentoo.org/838970 Bug: https://bugs.gentoo.org/863224 Bug: https://bugs.gentoo.org/875956 Closes: https://bugs.gentoo.org/862525 Closes: https://bugs.gentoo.org/863395 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/27812 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-6.4.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index b4fc1b99908c..6533bb0349f1 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,3 +1,4 @@
DIST qtwayland-5.15.5-gentoo-kde-2.tar.xz 35492 BLAKE2B 91334609155e4bd227d76e5972422b400ab4b6196389a1b6b4c271994287851bc3b624ae761ece1418037735784edf7740ed5337ef6972bf708c598c202b7e86 SHA512 2663b59c7647e8a7d5f64905be114fc1b248cd8e10c2eba6bddc25b74fbbc5216e8264f41f50b6368819664921e27dfe96d4c1556c0e56f8c3c2c0ed75a72080
DIST qtwayland-everywhere-opensource-src-5.15.5.tar.xz 567384 BLAKE2B 01ce4d546bda7bf332f8cc4f86a5e8bfb1be0ef60336ee3cae58266a25d51cf00fef3e6c4204f0179abc2ef748f88bd3a20f89f36da74d5d15c70ae7b4975186 SHA512 828dceb7bc54ce610a73f110f0aca332a90cf95df4a3bc971bd21c4e878366cb8d2248e609b73ce4d381579a143843c87a62f23dcc95767e522874e53a1b0327
DIST qtwayland-everywhere-src-6.3.2.tar.xz 836192 BLAKE2B 3cb7c72c37d4b69a798cd14cc9aca694ba6ed01330e71772653e841717dcdd1c6e0d77597066647430e5f52dd5cd48636e1a6a2dcaadc2ab86a52be803c90f92 SHA512 475ba168bacb2d35a5962b27542f43420e3baf42d2026699b272174076ee6a26f8c3663ba8e44508f2011c5b7a2e4b3086390264cdf621b393c79fe89265bd03
+DIST qtwayland-everywhere-src-6.4.0.tar.xz 836088 BLAKE2B 3efc506e1a0bc63182397d483bf352e21d39c75a7360ee3fe839527451950875748aea5cf62207ffef38b845a12c2bbbefde918d14333d1b194a4ea39b82670f SHA512 745fcc84c936c3f2fa7382291b5013679f9e57d6c680f1d352b0a132ba7cbaaea1495211f8fc4f1af85a81c711794987e4e05284d3ac06c94e92e9b601dae924
diff --git a/dev-qt/qtwayland/qtwayland-6.4.0.ebuild b/dev-qt/qtwayland/qtwayland-6.4.0.ebuild
new file mode 100644
index 000000000000..09413e556f22
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-6.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+BDEPEND="dev-util/wayland-scanner"
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtbase-${PV}*[gui,opengl]
+ =dev-qt/qtdeclarative-${PV}*
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"