summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-14 06:07:29 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-14 07:22:12 -0500
commit9379289794f7c6a9fc21797cf18afe3a995197d3 (patch)
treeaee3112e33ebdc7d7f17a6cfac27a65e04421365 /dev-qt/qtwebchannel/qtwebchannel-6.6.2.ebuild
parentdev-qt/qtwayland: add 6.6.2 (diff)
downloadgentoo-9379289794f7c6a9fc21797cf18afe3a995197d3.tar.gz
gentoo-9379289794f7c6a9fc21797cf18afe3a995197d3.tar.bz2
gentoo-9379289794f7c6a9fc21797cf18afe3a995197d3.zip
dev-qt/qtwebchannel: add 6.6.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtwebchannel/qtwebchannel-6.6.2.ebuild')
-rw-r--r--dev-qt/qtwebchannel/qtwebchannel-6.6.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-qt/qtwebchannel/qtwebchannel-6.6.2.ebuild b/dev-qt/qtwebchannel/qtwebchannel-6.6.2.ebuild
new file mode 100644
index 000000000000..196c658b4733
--- /dev/null
+++ b/dev-qt/qtwebchannel/qtwebchannel-6.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt WebChannel"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm64 ~loong"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[concurrent]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ has_version ">=dev-qt/qtdeclarative-${PV}:6" && #913692
+ local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
+
+ qt6-build_src_configure
+}