summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-06-20 21:33:31 +0300
committerSam James <sam@gentoo.org>2022-08-02 22:49:51 +0100
commit0ac0cccecd72547debeba29eeacbbace6f4f0b67 (patch)
treeaf94830da4e7a15b63102dd3f3f02cc5fa14e449 /dev-qt/qtwebengine
parentdev-qt/qtwebsockets: add version 6.3.1 (diff)
downloadgentoo-0ac0cccecd72547debeba29eeacbbace6f4f0b67.tar.gz
gentoo-0ac0cccecd72547debeba29eeacbbace6f4f0b67.tar.bz2
gentoo-0ac0cccecd72547debeba29eeacbbace6f4f0b67.zip
dev-qt/qtwebengine: add version 6.3.1
Bug: https://bugs.gentoo.org/838970 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt/qtwebengine')
-rw-r--r--dev-qt/qtwebengine/Manifest1
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-6.3.1-widevine.patch18
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild246
3 files changed, 265 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/Manifest b/dev-qt/qtwebengine/Manifest
index 282326e1c880..6db838137ef4 100644
--- a/dev-qt/qtwebengine/Manifest
+++ b/dev-qt/qtwebengine/Manifest
@@ -2,3 +2,4 @@ DIST qtwebengine-5.15.2-r1-chromium87-ppc64le.tar.xz 28784 BLAKE2B aa101d14446f3
DIST qtwebengine-5.15.2_p20211019-jumbo-build.patch.bz2 2930 BLAKE2B fca1d1406874d04eafb64bb4d8730512a6307ba44fb99d76f428ca1bd4a303758e0c3bd8f92a59f7bcf62e5b767c5a8ed239028bdb74ad7a8b62abf88d38c101 SHA512 61cbfbe4ff340b75ea8d356e031e932ac03fe65dd009999ff897ca4b0185d1d989490daf75ffeaaabb3e92c870c11c7ff8ad2cd6372f5363b3d774b8ecca6d89
DIST qtwebengine-5.15.3_p20220406-patchset.tar.xz 35480 BLAKE2B ce6aeebbb3255196611130d04ee7a3907ba45d6d2a283f2433e2176cf67e473e74137b180de0a9998762cc54439bb06825815e81e9f95f9413ce2956ac9308b7 SHA512 47e29a1429dce2db324929af91c8ef8421c75ae48f5a491db71b434f8017a5b1e7475e9938989e331e8e012220852848565242e09747892e1a8a8d3ab7386840
DIST qtwebengine-5.15.5_p20220618.tar.xz 320131236 BLAKE2B 842322c94737cdf647277ccf226c0d015ac0b362af54c4298cbad6b4494aa4ef0e73830577fb391be31c91b4331b85f407ec58641897a7cc7237e7623043577d SHA512 b1bab7aa5edc7f7b9d4f8338a05dbbd55ae6e0312e1a7e6061895bd7a98c67780127c20db1dbbc81664bf483a5b8f7ed887cedd1baaa1a0259e28fd4b13d6944
+DIST qtwebengine-everywhere-src-6.3.1.tar.xz 398269544 BLAKE2B 3b56a87fd93de0da9ccbfdeda0c5a3e07892dcb1c8dce848cc21c73cb45e7c94746bad299feaa68910ba036abf0c1c16fa423307fdc08c8af4e5e920e2e8a329 SHA512 e00601a7ec6400551f7707d15cf326340ae8d6a5bb8cda55df4619148414f4b3ca3daabfd7263dd5a2ff2ca8ba64f9e91c9db3f1a50bea4903148c57b6dc81dd
diff --git a/dev-qt/qtwebengine/files/qtwebengine-6.3.1-widevine.patch b/dev-qt/qtwebengine/files/qtwebengine-6.3.1-widevine.patch
new file mode 100644
index 000000000000..74da3f35f793
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-6.3.1-widevine.patch
@@ -0,0 +1,18 @@
+Backport from 6.3.2
+https://bugreports.qt.io/browse/QTBUG-104238
+https://github.com/qutebrowser/qutebrowser/issues/7231
+--- a/src/core/content_client_qt.cpp
++++ b/src/core/content_client_qt.cpp
+@@ -54,4 +54,5 @@
+ #include "media/base/media_switches.h"
+ #include "media/base/video_codecs.h"
++#include "media/cdm/supported_audio_codecs.h"
+ #include "media/media_buildflags.h"
+ #include "ui/base/layout.h"
+@@ -276,4 +277,6 @@
+ #endif // BUILDFLAG(USE_PROPRIETARY_CODECS)
+
++ capability->audio_codecs = media::GetCdmSupportedAudioCodecs();
++
+ // Add the supported encryption schemes as if they came from the
+ // component manifest. This list must match the CDM that is being
diff --git a/dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild b/dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild
new file mode 100644
index 000000000000..468f7bbc29d7
--- /dev/null
+++ b/dev-qt/qtwebengine/qtwebengine-6.3.1.ebuild
@@ -0,0 +1,246 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_REQ_USE="xml(+)"
+CHROMIUM_VER="94.0.4606.126"
+CHROMIUM_PATCHES_VER="101.0.4951.64"
+
+inherit check-reqs estack flag-o-matic multiprocessing python-any-r1 qt6-build
+
+DESCRIPTION="Library for rendering dynamic web content in Qt6 C++ and QML applications"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="
+ alsa bindist designer geolocation +jumbo-build kerberos pulseaudio screencast
+ +system-ffmpeg +system-icu widgets
+"
+REQUIRED_USE="designer? ( widgets )"
+
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/html5lib[${PYTHON_USEDEP}]')
+ dev-util/gperf
+ dev-util/ninja
+ dev-util/re2c
+ net-libs/nodejs[ssl]
+ sys-devel/bison
+ sys-devel/flex
+"
+RDEPEND="
+ app-arch/snappy:=
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/expat
+ dev-libs/libevent:=
+ dev-libs/libxml2[icu]
+ dev-libs/libxslt
+ dev-libs/re2:=
+ =dev-qt/qtdeclarative-${PV}*
+ =dev-qt/qtwebchannel-${PV}*
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/harfbuzz:=
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ >=media-libs/libvpx-1.5:=[svc(+)]
+ media-libs/libwebp:=
+ media-libs/opus
+ sys-apps/dbus
+ sys-apps/pciutils
+ sys-libs/zlib[minizip]
+ virtual/libudev
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libxcb:=
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ alsa? ( media-libs/alsa-lib )
+ geolocation? ( =dev-qt/qtpositioning-${PV}* )
+ kerberos? ( virtual/krb5 )
+ pulseaudio? ( media-libs/libpulse:= )
+ screencast? ( media-video/pipewire:= )
+ system-ffmpeg? ( media-video/ffmpeg:= )
+ system-icu? ( >=dev-libs/icu-69.1:= )
+ widgets? (
+ =dev-qt/qtbase-${PV}*[widgets]
+ )
+"
+DEPEND="${RDEPEND}
+ media-libs/libglvnd
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-widevine.patch
+)
+
+python_check_deps() {
+ python_has_version "dev-python/html5lib[${PYTHON_USEDEP}]"
+}
+
+qtwebengine_check-reqs() {
+ # bug #307861
+ eshopts_push -s extglob
+ if is-flagq '-g?(gdb)?([1-9])'; then
+ ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
+ ewarn "You may experience really long compilation times and/or increased memory usage."
+ ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
+ fi
+ eshopts_pop
+
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ # (check-reqs added for bug #570534)
+ #
+ # Estimate the amount of RAM required
+ # Multiplier is *10 because Bash doesn't do floating point maths.
+ # Let's crudely assume ~2GB per compiler job for GCC.
+ local multiplier=20
+
+ # And call it ~1.5GB for Clang.
+ if tc-is-clang ; then
+ multiplier=15
+ fi
+
+ local CHECKREQS_DISK_BUILD="7G"
+ local CHECKREQS_DISK_USR="150M"
+ if ! has "distcc" ${FEATURES} ; then
+ # bug #830661
+ # Not super realistic to come up with good estimates for distcc right now
+ local CHECKREQS_MEMORY=$(($(makeopts_jobs)*multiplier/10))G
+ fi
+
+ check-reqs_${EBUILD_PHASE_FUNC}
+}
+
+pkg_pretend() {
+ qtwebengine_check-reqs
+}
+
+pkg_setup() {
+ qtwebengine_check-reqs
+ python-any-r1_pkg_setup
+}
+
+pkg_preinst() {
+ elog "This version of Qt WebEngine is based on Chromium version ${CHROMIUM_VER}, with"
+ elog "additional security fixes up to ${CHROMIUM_PATCHES_VER}. Extensive as it is, the"
+ elog "list of backports is impossible to evaluate, but always bound to be behind"
+ elog "Chromium's release schedule."
+ elog "In addition, various online services may deny service based on an outdated"
+ elog "user agent version (and/or other checks). Google is already known to do so."
+ elog
+ elog "tldr: Your web browsing experience will be compromised."
+}
+
+src_unpack() {
+ # bug 307861
+ eshopts_push -s extglob
+ if is-flagq '-g?(gdb)?([1-9])'; then
+ ewarn
+ ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
+ ewarn "You may experience really long compilation times and/or increased memory usage."
+ ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
+ ewarn
+ fi
+ eshopts_pop
+
+ case ${QT6_BUILD_TYPE} in
+ live) git-r3_src_unpack ;&
+ release) default ;;
+ esac
+}
+
+src_prepare() {
+ # bug 620444 - ensure local headers are used
+ find . -type f -name "*.pr[fio]" -exec \
+ sed -i -e 's|INCLUDEPATH += |&$${QTWEBENGINE_ROOT}_build/include $${QTWEBENGINE_ROOT}/include |' {} + || die
+
+ if use system-icu; then
+ # Sanity check to ensure that bundled copy of ICU is not used.
+ # Whole src/3rdparty/chromium/third_party/icu directory cannot be deleted because
+ # src/3rdparty/chromium/third_party/icu/BUILD.gn is used by build system.
+ # If usage of headers of bundled copy of ICU occurs, then lists of shim headers in
+ # shim_headers("icui18n_shim") and shim_headers("icuuc_shim") in
+ # src/3rdparty/chromium/third_party/icu/BUILD.gn should be updated.
+ local file
+ while read file; do
+ echo "#error This file should not be used!" > "${file}" || die
+ done < <(find src/3rdparty/chromium/third_party/icu -type f "(" -name "*.c" -o -name "*.cpp" -o -name "*.h" ")" 2>/dev/null)
+ fi
+
+ qt6-build_src_prepare
+}
+
+src_configure() {
+ export NINJA_PATH="${BROOT}"/usr/bin/ninja
+ export NINJAFLAGS="${NINJAFLAGS:--j$(makeopts_jobs) -l$(makeopts_loadavg "${MAKEOPTS}" 0) -v}"
+
+ local mycmakeargs=(
+ #-DQT_FEATURE_accessibility=off
+ #-DQT_FEATURE_force_asserts=off
+ #-DQT_FEATURE_opengl=off
+ #-DQT_FEATURE_printer=off
+ -DQT_FEATURE_qtpdf_build=off
+ -DQT_FEATURE_qtpdf_quick_build=off
+ -DQT_FEATURE_qtpdf_widgets_build=off
+ -DQT_FEATURE_qtwebengine_build=on
+ -DQT_FEATURE_qtwebengine_quick_build=on
+ -DQT_FEATURE_qtwebengine_widgets_build=on
+ #-DQT_FEATURE_ssl=off
+ #-DQT_FEATURE_static=off
+ #-DQT_FEATURE_system_zlib=off
+ #-DQT_FEATURE_system_png=off
+ #-DQT_FEATURE_system_jpeg=off
+ #-DQT_FEATURE_system_freetype=off
+ #-DQT_FEATURE_system_harfbuzz=off
+ #-DQT_FEATURE_use_gold_linker=off
+ #-DQT_FEATURE_use_lld_linker=off
+ -DQT_FEATURE_webengine_embedded_build=off
+ -DQT_FEATURE_webengine_extensions=on
+ #-DQT_FEATURE_webengine_full_debug_info=$(usex debug)
+ -DQT_FEATURE_webengine_geolocation=$(usex geolocation on off)
+ -DQT_FEATURE_webengine_jumbo_build=$(usex jumbo-build)
+ #-DQT_FEATURE_webengine_jumbo_file_merge_limit
+ -DQT_FEATURE_webengine_kerberos=$(usex kerberos on off)
+ -DQT_FEATURE_webengine_native_spellchecker=off
+ -DQT_FEATURE_webengine_ozone_x11=on
+ -DQT_FEATURE_webengine_pepper_plugins=on
+ -DQT_FEATURE_webengine_proprietary_codecs=$(usex bindist off on)
+ -DQT_FEATURE_webengine_printing_and_pdf=on
+ -DQT_FEATURE_webengine_sanitizer=on
+ -DQT_FEATURE_webengine_spellchecker=on
+ -DQT_FEATURE_webengine_system_opus=on
+ -DQT_FEATURE_webengine_system_libwebp=on
+ -DQT_FEATURE_webengine_system_alsa=$(usex alsa on off)
+ -DQT_FEATURE_webengine_system_ffmpeg=$(usex system-ffmpeg)
+ -DQT_FEATURE_webengine_system_icu=$(usex system-icu)
+ -DQT_FEATURE_webengine_system_libevent=on
+ -DQT_FEATURE_webengine_system_libpci=on
+ -DQT_FEATURE_webengine_system_libpng=on
+ -DQT_FEATURE_webengine_system_pulseaudio=$(usex pulseaudio on off)
+ -DQT_FEATURE_webengine_system_zlib=on
+ -DQT_FEATURE_webengine_webchannel=on
+ -DQT_FEATURE_webengine_webrtc=on
+ -DQT_FEATURE_webengine_webrtc_pipewire=$(usex screencast on off)
+ #-DQT_FEATURE_xcb=off
+ )
+
+ qt6-build_src_configure
+}