summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-26 11:18:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-26 16:32:27 +0200
commitaeb61e1abdbb629279cb188180567a3fb957d9e5 (patch)
tree1425b69473c31cd902abba3a496763dd2a325396 /dev-qt/qtxml/qtxml-5.15.0.ebuild
parentqt5-build.eclass: Drop pre-Qt 5.14 quirks (diff)
downloadgentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.tar.gz
gentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.tar.bz2
gentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.zip
dev-qt: Add Qt 5.15.0 release
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtxml/qtxml-5.15.0.ebuild')
-rw-r--r--dev-qt/qtxml/qtxml-5.15.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-qt/qtxml/qtxml-5.15.0.ebuild b/dev-qt/qtxml/qtxml-5.15.0.ebuild
new file mode 100644
index 000000000000..c475c1b3f0d3
--- /dev/null
+++ b/dev-qt/qtxml/qtxml-5.15.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}:5=
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtnetwork-${PV} )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/xml
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :xml
+)