summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-09 22:28:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-10 19:41:48 +0200
commitc60b2b11bd17afca9bbe546db12918f789b57e25 (patch)
treeab73bbfc4ed431e679f408af614605d97b452479 /dev-qt/qtxml/qtxml-5.15.1.ebuild
parentmedia-gfx/digikam: 7.1.0 version bump (diff)
downloadgentoo-c60b2b11bd17afca9bbe546db12918f789b57e25.tar.gz
gentoo-c60b2b11bd17afca9bbe546db12918f789b57e25.tar.bz2
gentoo-c60b2b11bd17afca9bbe546db12918f789b57e25.zip
dev-qt: Add Qt 5.15.1
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtxml/qtxml-5.15.1.ebuild')
-rw-r--r--dev-qt/qtxml/qtxml-5.15.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-qt/qtxml/qtxml-5.15.1.ebuild b/dev-qt/qtxml/qtxml-5.15.1.ebuild
new file mode 100644
index 000000000000..c475c1b3f0d3
--- /dev/null
+++ b/dev-qt/qtxml/qtxml-5.15.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}:5=
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtnetwork-${PV} )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/xml
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :xml
+)