summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-14 07:01:33 +0000
committerSam James <sam@gentoo.org>2022-05-14 21:22:28 +0000
commit004ae99be115c5409f1287e6128975e51829896c (patch)
tree14614588a3eb3fff89f67c76643f25f0d595f773 /dev-qt
parentsci-geosciences/qgis: add 3.22.7 (diff)
downloadgentoo-004ae99be115c5409f1287e6128975e51829896c.tar.gz
gentoo-004ae99be115c5409f1287e6128975e51829896c.tar.bz2
gentoo-004ae99be115c5409f1287e6128975e51829896c.zip
dev-qt/qtwebengine: fix build with GCC 12
Closes: https://bugs.gentoo.org/840326 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.15.3_p20220406-gcc12-includes.patch32
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.3_p20220406.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.15.3_p20220406-gcc12-includes.patch b/dev-qt/qtwebengine/files/qtwebengine-5.15.3_p20220406-gcc12-includes.patch
new file mode 100644
index 000000000000..cd476564037a
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.15.3_p20220406-gcc12-includes.patch
@@ -0,0 +1,32 @@
+https://build.opensuse.org/package/view_file/KDE:Qt:5.15/libqt5-qtwebengine/0001-skia-Some-includes-to-fix-build-with-GCC-12.patch?expand=1
+https://bugs.gentoo.org/840326
+
+From 68799a1e0815b20ca59ce354a55280399257a201 Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fvogt@suse.de>
+Date: Fri, 25 Mar 2022 15:29:28 +0100
+Subject: [PATCH] skia: Some includes to fix build with GCC 12
+
+Those includes got introduced upstream for other reasons and fixed building
+with GCC 12 as a side effect.
+--- a/src/3rdparty/chromium/third_party/skia/include/core/SkColor.h
++++ b/src/3rdparty/chromium/third_party/skia/include/core/SkColor.h
+@@ -12,6 +12,8 @@
+ #include "include/core/SkScalar.h"
+ #include "include/core/SkTypes.h"
+
++#include <array>
++
+ /** \file SkColor.h
+
+ Types, consts, functions, and macros for colors.
+--- a/src/3rdparty/chromium/third_party/skia/src/utils/SkParseColor.cpp
++++ b/src/3rdparty/chromium/third_party/skia/src/utils/SkParseColor.cpp
+@@ -8,6 +8,8 @@
+
+ #include "include/utils/SkParse.h"
+
++#include <algorithm> // std::lower_bound
++
+ static constexpr const char* gColorNames[] = {
+ "aliceblue",
+ "antiquewhite",
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.3_p20220406.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.3_p20220406.ebuild
index 6a665711c4c2..db0d242c1aa1 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.3_p20220406.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.3_p20220406.ebuild
@@ -109,6 +109,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.15.2_p20210224-disable-git.patch" # downstream snapshot fix
"${FILESDIR}/${PN}-5.15.2_p20211015-pdfium-system-lcms2.patch" # by Debian, QTBUG-61746
"${FILESDIR}/${PN}-5.15.3_p20220329-clang14.patch" # by FreeBSD, bug 836604
+ "${FILESDIR}/${PN}-5.15.3_p20220406-gcc12-includes.patch" # by openSUSE, bug 840326
"${WORKDIR}/${PN}-5.15.2_p20211019-jumbo-build.patch" # bug 813957
"${WORKDIR}/${PN}-5.15.3_p20220406-patchset" # bug 698988 (py2--), pipewire-3
)