summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-26 11:17:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-26 11:34:00 +0200
commit0e580f0a29959b82b35946960a668afa07734fc7 (patch)
tree20de66a4e67c6f7ef2cf89fc23773ae36d8beae3 /dev-qt
parentdev-qt/qt3d: Force -system-assimp (diff)
downloadgentoo-0e580f0a29959b82b35946960a668afa07734fc7.tar.gz
gentoo-0e580f0a29959b82b35946960a668afa07734fc7.tar.bz2
gentoo-0e580f0a29959b82b35946960a668afa07734fc7.zip
dev-qt/qtlocation: Add missing qtlocation-mapboxgl snapshot
Closes: https://bugs.gentoo.org/810436 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild9
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 2cf39e97ff8e..7c53765f8f15 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,2 +1,3 @@
DIST qtlocation-5.15.2-861e372b.tar.gz 5431120 BLAKE2B c66e81f7e726b53000a0f8a4eafa9a4a6168aa08c89d4d0e2ef11b02e3598fd0b3f30dbd21e6c5436814bb88fa69c96d141b0d0d79f13239ec61396269af089a SHA512 b7cac8cd42185504c6140f1dcd4e8c0c749e3d8f22bf9977e97268e0ad6fbd3733e571a255ab7824eba31e30e707e804b07317f2ec9b7be15a4a5756c78c9e41
DIST qtlocation-everywhere-src-5.15.2.tar.xz 6556764 BLAKE2B a322f35ece266fff6428da9090f02c0d5749a4750ff0655ef09695f147d88d667b5917335e44d0f8721cc56f425c171fb11d0f34342aff005327518e9c1d6db8 SHA512 6192922506b3ea354e85431df83c19d7cc9aebb17549c6a1de48f625bf8365ff3db3161080dde254a5fb9199d99c3c5dc8e1533429150be55df96ddb7d6ce16f
+DIST qtlocation-mapboxgl-5.15.2-d3101bbc.tar.gz 3726244 BLAKE2B e571a72e041b80b155eae7d171cee7f996fbe223c8d3337f549ea2a40472fc2da9dd8abf54238f22c1828d467aaf01307a61acecd3aedc4f5f7cabc06f48d830 SHA512 6e38e5ca0b9e17de690af79f4702278bdc933a74561aa135b3e82245df7d795602403048bcc5bce00237f774ce3957540a8bded1a71f8730a08da05dec1f039f
diff --git a/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild b/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
index f5324144a067..bd4507627705 100644
--- a/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
@@ -9,6 +9,8 @@ inherit qt5-build
DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ MAPBOXGL_COMMIT=d3101bbc22edd41c9036ea487d4a71eabd97823d
+ SRC_URI+=" https://invent.kde.org/qt/qt/${PN}-mapboxgl/-/archive/${MAPBOXGL_COMMIT}/${PN}-mapboxgl-${MAPBOXGL_COMMIT}.tar.gz -> ${PN}-mapboxgl-${PV}-${MAPBOXGL_COMMIT:0:8}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi
@@ -39,6 +41,13 @@ QT5_TARGET_SUBDIRS=(
src/plugins/geoservices
)
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+src_prepare() {
+ mv "${WORKDIR}"/${PN}-mapboxgl-${MAPBOXGL_COMMIT}/* src/3rdparty/mapbox-gl-native || die
+ qt5-build_src_prepare
+}
+fi
+
src_configure() {
# src/plugins/geoservices requires files that are only generated when
# qmake is run in the root directory. Bug 633776.