summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorDenis Pronin <dannftk@yandex.ru>2020-02-17 19:05:04 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-16 22:25:46 +0100
commit1b0016ad3a79aacb76423b81c01cfbc30cfd01e5 (patch)
tree336d8f5c51d1c3925e3dd28a2ed47e69cc8ad72a /dev-qt
parentkde-misc/kio-gdrive: Fix build with >=kaccounts-integration-20.04 (diff)
downloadgentoo-1b0016ad3a79aacb76423b81c01cfbc30cfd01e5.tar.gz
gentoo-1b0016ad3a79aacb76423b81c01cfbc30cfd01e5.tar.bz2
gentoo-1b0016ad3a79aacb76423b81c01cfbc30cfd01e5.zip
dev-qt/qtbluetooth: fix build with with clang++ and libc++
Signed-off-by: Denis Pronin <dannftk@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/14686 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtbluetooth/files/qtbluetooth-5.14.1-errno.patch25
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.14.1.ebuild2
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/files/qtbluetooth-5.14.1-errno.patch b/dev-qt/qtbluetooth/files/qtbluetooth-5.14.1-errno.patch
new file mode 100644
index 000000000000..7f1ae712bd16
--- /dev/null
+++ b/dev-qt/qtbluetooth/files/qtbluetooth-5.14.1-errno.patch
@@ -0,0 +1,25 @@
+From 58e0224a6677667b1102b34ad5b35a787bd74077 Mon Sep 17 00:00:00 2001
+From: Denis Pronin <dannftk@yandex.ru>
+Date: Wed, 4 Mar 2020 00:59:07 +0300
+Subject: [PATCH] support building with clang and libc++
+
+fixed undefined errno when compiling with clang++ and libc++
+
+Change-Id: I30be6e2da36f9189261535f103ce689462634f49
+Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
+---
+ src/bluetooth/bluez/bluetoothmanagement.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/bluetooth/bluez/bluetoothmanagement.cpp b/src/bluetooth/bluez/bluetoothmanagement.cpp
+index 31d3dc02..b6ad93e5 100644
+--- a/src/bluetooth/bluez/bluetoothmanagement.cpp
++++ b/src/bluetooth/bluez/bluetoothmanagement.cpp
+@@ -51,6 +51,7 @@
+ #include <sys/types.h>
+ #include <linux/capability.h>
+
++#include <cerrno>
+
+ QT_BEGIN_NAMESPACE
+
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.14.1.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.14.1.ebuild
index 7ded615ebf54..6d4771dedd5a 100644
--- a/dev-qt/qtbluetooth/qtbluetooth-5.14.1.ebuild
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.14.1.ebuild
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
~dev-qt/qtnetwork-${PV}
"
+PATCHES=( "${FILESDIR}/${P}-errno.patch" )
+
src_prepare() {
sed -i -e 's/nfc//' src/src.pro || die